Windows 7 Pro; cannot upgrade IE8 to IE 10 or IE 11

November 17, 2016 at 10:19:28
Specs: IOS, .../lots...
I have Windows 7 Pro - 64Bit - installed (via Bootcamp) on a Mac Mini; lots of hard drive space free in that partition. Currently it includes M$ Security Essentials (or whatever it's called).

It boots fine either as stand alone or via Parallels.. Problem is that IE 8 is the default browser, and that's now way out of date and no longer supported..

When I attempt to upgrade to IE 10 or IE 11... The upgrade/download process goes into an endless searching for downloaded updates; it never finds any and never actually stops searching. I have to use Task Manager to stop the process. This happens when I run it from a downloaded updater file or run it "online".

If I download a full version of IE 10 or IE 11 and run that... the system goes into install routine; then says it's restarting (assorted) programmes; then say it couldn't complete the installation and to seek help (there being an icon on the desktop to this end).

Using that "help" system merely takes me assorted downloads for IE 10 and IE 11, and even downloading one or two updates that are said to address some updating issues, the problem persists.

To make matters even more complicated when one follows the trouble-shooter installed on the desktop, it uses IE; and mine is IE 8 and the message comes up to upgrade to a later version as IE 8 is no longer supported, and I can go no further using my out of date IE 8. I then use Firefox to at least access/download assorted updates etc... But cannot get either IE 10 or IE 11 to install via either the full stand alone version, or the online updater...

T'is an endless loop...

What is a going on here?

I became aware of this problem when trying to instal Bitdefender freebie for Windows. Bitdefender want IE as the browser of choice to allow me to install Bitdefender... Not quite sure why but it does...

- au barricades, au secours mes amis, m'aide... (mayday).

In other words can anyone shed light on the problem and even better a working resolution (please)?

message edited by trvlr


See More: Windows 7 Pro; cannot upgrade IE8 to IE 10 or IE 11

Report •

#1
November 17, 2016 at 10:47:24
Do you have SP1 and the rollups for Windows 7 installed?

Report •

#2
November 17, 2016 at 11:25:01
SP1 yes. When I try the rollups the setup routine goes into searching for updates and doesn't ever finish searching (for updates); and I leave it for an age - actually overnight on one occasion...

Report •

#3
November 17, 2016 at 13:00:36

Report •

Related Solutions

#4
November 17, 2016 at 14:03:12
Trying that KB now - with win-7 booting via Parallels.

I've tried with several versions of that installer; and always it just "searches for updates on the computer" and never gets anywhere... I'll leave it (again) overnight and see/hope etc...


Report •

#5
November 17, 2016 at 17:06:50
Overnight may not be long enough. Wait till it comes up with a (error) massage or the 200+ updates to install.

Report •

#6
November 18, 2016 at 01:51:22
Update, having left it on overnight... the "searching for updates on the computer" is still displayed.

Valid point about the time required; will leave things running another 24 hrs - shudder to think of the hamsters having to run without a break for that long...


Report •

#7
November 18, 2016 at 10:04:37
I don't work with Macs so I have no idea if that has anything to do with your problems or not. But the KB I posted a link to (KB3102810) fixes a problem with Update Agent version 7.6.7600.320 which, once installed, prevents Windows Update from working properly. Check to see which version you currently have.

https://deskroll.com/blog/article.p...


Report •

#8
November 18, 2016 at 12:05:08
Now that's interesting... I have tried to instal KB3102810 - and it fails; it simply won't go in... I have tried that a few times already; the update routine gets lost searching for updates in the computer and never finds any.

The version of the updater I have is the one in the link posted in #7 above.

When I follow step two in that link and look for updates - there are lots for Office and Outlook and Adobe... but "none' for windows...

And having tried to install the rollup package (downloaded asa full item) that fails with the message that windows couldn't complete that installation (update) and use the help option (now an icon on the desktop) - see my initial post for the whole routine I have gone through thus far...

I do recall getting an indication (in the system tray via an icon there which has long gone..) that there were 29% of downloads installed; and later that went up to 31%. But was booting directly into windows via Apple's Bootcamp (boot manager) - rather than via Parallels VM route which runs within Mac OS itself... Even to get that far I had to leave it overnight...


Report •

#9
November 18, 2016 at 12:13:29
Correction... after posting the above response I went back to looking for windows updates as above - and now there "quite a few"... i.e 245 updates shown.

message edited by trvlr


Report •

#10
November 18, 2016 at 12:16:02
trvlr

I had a similar issue a while back. I think it was one of my older programs that Windows 7 doesn't like running at startup. Try shutting down older hardware and stuff like Ccleaner. Then reboot and try the updates again.


Report •

#11
November 18, 2016 at 12:20:59
Ah... now there's a thought; even though I seem to have the latest version of ccleaner...

Might it work if I tried safe-mode?


Report •

#12
November 18, 2016 at 12:27:00
Trawling the web does bring out that this is an olde (and ongoing) issue... and even now with windows-10

I found this on the fly...

http://tinyurl.com/jq3t4pp

I need to eat... it's a little past my dinner time; almost supper time... Will pursue this more later. Meanwhile thanks for the thoughts and ideas - please to keep them coming... Hopefully between us all we can resolve this problem; and even get IE10 or 11 installed; although I generally use Firefox more in windows.

message edited by trvlr


Report •

#13
November 29, 2016 at 07:58:16
An update - and "success" at that...

I did have (still do of course) have SP-1 installed.; and tried al of the helpful ideas posted earlier - again for which many thanks.

I did try with ccleaner switched of - no difference.

Having further trawled the universe, assorted black holes and other places, installed assorted "suggested" specific versions of some of the numerous M$ KB updates (various web resources suggested that, including CN); (there are several such updates that allegedly resolve the problem I and many others experienced) I finally managed to get a whole slew of updates installed (it took almost 48hrs...); but not the win-7 rollup nor IE 10.

Left it all alone for a while (affairs of state) and then had another go to day - Nov 29th. This time the previous win-7 rollup was listed (not the current previewed November 2016 version). Also present were IE 9 and IE 10. I opted for the assorted updates (the original rollup included) and IE 10; IE 10 failed yet again. Rebooted and went for more updates - not including IE 10, but did opt for IE 9. Those updates went in OK - and so did IE 10 (which I had "not" opted to try for at that time). Work that out...

Why - I can only guess that the original rollup went in with something useful in this regard, and also some of the more recent single updates may have resolved the initial problem too?

There are times when one wonders just where M$ software developers and "phyxers" really inhabit. Dishing out updates - let alone dodgy the initial software to start with - is no way to inspire confidence. For me an occasional windows user these days (I'm now most Mac systems), the time, energy wasted wasn't too great a hardship; didn't cost me money... But for those who run windows various, use it earn their daily crusts and moonshine etc..... the story is different.

I wish I could say definitely what the actual solution was but I can't. I think the original rollup (as suggested by others earlier) may have impacted - but it also required back up as it were from other stand alone later updates. What is odd that initially that original rollup wouldn't install either, way back when first I posted this CFH; or appears not to have since it was later flagged as being an "essential" update......

Possible advice for any in the future:

Ensure you have the latest wuu installed (as per advised earlier by others here).

Install the original rollup if you haven't already; then start installing (in small lots) separate updates and see what happens?

I'm avoiding IE 11 for now; but if you have any comments/advice installing that (is it worth it) please do feel phree to advise...

Time to go back to dos 6x and win-3/3,11 etc.?

Thanks to all who pointed in the right direction - it was useful starting point; though, as I say, quite where I ended up and found exactly what the solution was/is - ???


Report •

Ask Question