Solved Windows 7 - No C drive partition

April 27, 2014 at 22:30:47
Specs: Windows 7
I don't know why these discussions end before anything gets resolved!
I have had 3 computers "infected" with an X drive, the most recent, a Gateway laptop, has a D, E, F, G and X drives. The only drives with anything on them are D and X. The D only has a few files on it while the X seems to have a "Windows" system on it, although only 5 directories, one of which states "Access denied" when I attempt to get into it.
I have taken more than 100 photos of the screen shots as I opened each directory, and looking at some of the log files, it makes me believe that this whole "X" drive thing is malware/trojan/virus.
It started slowly taking control of my computer...SD cards wouldn't read, wouldn't download updates, couldn't make changes to things that I had changed before, couldn't get into files that I could get into previously.
When I tried using System Restore, there were only 2 restore points (10% of hard drive able to use for restore).
It started getting so bad that I couldn't get online. That's when I found "locked" files in the "Guest" account...the account was turned off!
The "Bluetooth" logo was also in that account, which suggested to me that someone had to be trying to use bluetooth to do their dirty work...maybe steal info.
After trying System Restore, I tried Last Known Good Configuration, Safe Modes (all 3), and after saving my files, I started trying to do the System Recovery as the last resort. Everytime that I tried to "retry" one of the
previously tried options, the system would remember what I had done and present me with some error message or lock into some screen that didn't go anywhere or get anything done!
What a nightmare from hell! My first experience with this "X" drive problem was with 2 computers that I had the "pleasure" of returning to normal. The first one, a Dell laptop, I was able to save data files from using a USB drive reader and reinstall XP using the OEM disks supplied with the computer. The second, another Dell, I
saved the files using the same USB drive reader and reinstalled the OS.
The Sony laptop computer (Windows 7) that I had used with the USB drive reader then became infected with the same "X" drive problem...the only difference was that the Sony couldn't be repaired using the Recovery Disks, the Recovery partition, nor the repair disk that I purchased from Sony. The problem got worse with this one...the backlight quit working and I could see what was on the screen by shining an LED flashlight on the screen or letting the sun shine on it at a certain angle. I tried this for a week and finally wiped the drive clean and got rid of it.
Next, I had the same problem with my HP Vista desktop, and I can't figure out how it became infected.
Perhaps when I moved my email from the Sony to the desktop, or maybe some USB flashdrive that was shared between the two? I was able to use the Recovery disks to get Vista back on that one, but I don't trust using it for email.
Which brings me to the same problem with my new Gateway. also Windows 7. It has the "X" drive problem, which I have tried the Recovery disk set, the Recovery partition, and several different "Rescue" disks, none of which work. I can use the disks to boot to Windows but none of the repair options work. I used the Gateway manual and followed ALL of the recovery/reinstall info but nothing works. If I just try to boot with the
installed system, a window tells me to use the Windows 7 install disk to recover the OS...now, this is the only screen that appears using F1, F3 thru F11. I can still get into the BIOS with F2, and F12 is working to allow
me to boot to CD disk.

Microsoft, Sony, and all of the internet "fix-it" sites have been useless. None of them have ever offered a solution. Sony was of no help because my computer was out of warranty. And now, Microsoft updates has expired on XP software. Now what?!?

Maybe Jesse Ventura should check this one out as a "conspiracy" theory...has "someone" or "some computer" created a program that "steals" your data and then causes the computer to die in order to get you to purchase a new computer? And then the process repeats itself? Nobody seems to have an answer to solve this "X" drive problem...any suggestions?

Update: Today I wiped the drive clean (write all 0's) and installed Windows 7 using new Gateway software that I purchased last week. (One thing I noticed while wiping the 500Gb drive was that it was only wiping 465Gb...don't know why.) The install took a couple of hours and when things were working, I uninstalled some of the programs that I don't use, and I connected to the web and installed Windows Updates (118). While the updates were at stage 3 of "configuring", the computer restarted at 35% and seemed to continue with the "configuration". Then I uninstalled Norton, defragged, and installed Webroot. Did a scan and only found that "anti-phishing" was not turned on.
I was just going to change a few settings when the black screen of death with a "crash" screen appeared and quickly disappeared. Now, I can't boot without using a cd, and I now have the X drive problem back again with only 4 Directories.
If anyone has a genuine solution, I'd like to hear from you, or, if you know who does HDD analysis???

message edited by Spacebook


See More: Windows 7 - No C drive partition

Report •

#1
April 28, 2014 at 07:44:10
Writing all zeros was unnecessary. All you had to do was delete ALL partitions, create one or more new ones, then proceed with the Windows installation. It all could have been done using the Windows disk.

"One thing I noticed while wiping the 500Gb drive was that it was only wiping 465Gb...don't know why"

Not a problem, it's perfectly normal. The difference is the advertised capacity vs the actual capacity. In the future, just multiply the the advertised capacity x 0.931 to find the approx "true" capacity. 500GB x 0.931 = 465.5GB. Or you can use this HDD calculator:

http://www.ussscctv.com/harddrivesi...

You mentioned that "SD cards wouldn't read". Are you using them, USB jump drives, or external drives to install programs? If so, it's possible one of these devices is infected & re-contaminating your main HDD. I assume that all 3rd party software you're installing is legit & not pirated? You should NOT have any external devices (other than mouse & keyboard) connected to the computer when doing a Windows installation. And if your computer(s) doesn't have a floppy drive, make sure the floppy is disabled in the BIOS & not included in the boot order.


Report •

#2
April 28, 2014 at 07:44:44
✔ Best Answer
"One thing I noticed while wiping the 500Gb drive was that it was only wiping 465Gb...don't know why"

Nothing wrong there my friend. 500 GB is the decimal capacity, whereas the true binary capacity is 465 GB. Same with a 1 TB drive, it's true binary capacity is only 931 GB.

It's the drive maker's fault for insisting on quoting the decimal capacity, but they all do it.
None of them wants to be the first to quote capacity based on the true binary figure.

For the drive which is proving to be a pain in the butt, you can test it with the drive maker's diagnostic software for DOS which loads from a boot CD. The links for the CD images are here: http://www.tacktech.com/display.cfm...

For WD drives, the link is here: http://www.smartestcomputing.us.com...

You can use IMGBURN to create the CD from a CD Image:
http://www.filehippo.com/download_i...

message edited by phil22


Report •

#3
April 28, 2014 at 15:50:29
I did notice something else in your explanation though I cannot be sure it is related. You cannot use Norton and Webroot (other than the really old Spysweeper they used to offer) together, they will create problems for each other. Uninstall Norton and use only Webroot Secure Anywhere and if you need it, Malwarebytes can be used manually as needed.

Are you sure that the copies of your installed programs including Webroot and Norton are from actual mfg's disks or downloaded from the factory sites? Anything else, could be the source of your infection (a bogus Norton Disk say, or off site download could be the source of the repeat infection on multiple systems). Look carefully at all things that the systems have in common like the flash drive, common program install, home network drive, regularly visited web site(s), etc. There has to be something in common between the systems (other than just you) that has caused this problem you are seeing, especially since it does not appear to be a common problem for anyone else.

You have to be a little bit crazy to keep you from going insane.


Report •

Related Solutions

#4
April 28, 2014 at 21:16:06
Thanks Riider!
According to the Gateway Recovery disks, "all data has to be removed" before reinstalling to "factory" setup. I tried doing it without wiping all data but it didn't work. The only other options were reinstalling just the "C" drive, which I tried and didn't work, or a Windows recovery which is nothing more than "system restore", which also didn't work.
I appreciate the info on the size of the HDD...I was led to believe that if you purchased a computer with a 500Gb drive, you had access to all except the Windows and Recovery partitions. Gateway also has another partition that is 100Mb.

Report •

#5
April 28, 2014 at 21:40:41
Thanks phil22,
I've burned the .iso...will be testing it tomorrow.

Report •

#6
April 28, 2014 at 22:18:26
Thanks for the input Fingers!
I did state that I uninstalled Norton before I installed Webroot. Norton was preinstalled when I purchased the Gateway. I had used a preinstalled version of Norton on my Windows Vista system...didn't like it because it required a restart after almost every update. I had researched "top 10" antivirus programs and my final choices were between Webroot and BitDefender. I obtained the CD version because I like having a hard copy of my programs and went with Webroot because it was a recommendation from the "Geek Squad".
I had scanned my flash drives, SD cards and nothing was found, however, if the computer was already infected, it may have given a "false" report. When I explore them, I'm not really sure what to look for...seems that the X drive Windows system is a fairly large file system.
About the only other "common" items would be my modem, wireless router, and a USB drive that I used for backups which I also scanned and there were no problems found.

Report •

#7
April 29, 2014 at 00:50:33
About the 500 gig vs 465 you found; I went through the math of it here:

http://www.computing.net/answers/ha...

I don't understand this X drive thing. If you wiped the entire drive by writing zeros to it and then used all that space to install 7, there wouldn't be any space left to create another drive. Either you didn't wipe it all and left a restore or reserve partition or the X: drive is a USB drive. Weren't Norton ghost image files sometimes stored on a Drive X?

message edited by DAVEINCAPS


Report •

#8
April 30, 2014 at 13:18:23
I not only wiped the drive once, but 3 times using 2 different wipers, the last one wrote all zeros. I then formatted the drive for NTFS using my LinuxRecovery disk. I reinstalled Windows and all was working well until I did Windows updates (118 of them). On other reinstalls, I never had a problem doing updates, even with 100+. This time, when the updates were completely downloaded, the updates started to install and then the system crashed with a black screen with blue writing on it. I only was able to read something about "crash" before the computer restarted.
After Windows started, I uninstalled the bloatware and Norton, installed Webroot, and scanned the computer with Webroot, Windows Defender, and MRT (Windows Software Removal Tool). No viruses found, but when I opened the Command Prompt, there it was...Administrator X: was back. I found out that while you're in Admin X:, none of the usual commands would work: Fdisk, Diskpart, sfc /scannow. I could change directories but many would not let me access them: Access Denied.
I decided to try something different, something that I read on the web, that was used to solve some other problem...I unplugged the power cord, removed the battery, and pressed the power on button for 30 seconds. I left the computer off overnight.
To my amazement, my desktop and all my files were back. I immediately opened the Command Prompt and found that I was back in C drive! All of my updates were downloaded on the computer so I installed 5-10 at a time...worked ok.
I'm proceeding with caution because this has happened before. I'm installing one program at a time, one document file at a time, and try to find out if there is a particular file or program that is "infecting" my computer with a drive X.
phil22 - I burned the .iso for a Seagate, which my linux disk stated was in my computer, but the first burn didn't work (wasn't logged on as administrator). Burned again...program worked but reported that there was no HDD, so I can't run the tests.
I might pull the drive to see what it is and get the correct download...Thanks for the link!
Thanks to all for your help and info. If I find out what program or file is involved with "Admin X:" or Drive X, I will post. I don't know if .jpeg files can be infected, but as I have thousands to go thru, it might be awhile.

Report •

#9
April 30, 2014 at 16:41:00
I have been using Webroot for many years and think that the latest version is probably the best out there. I especially like that it does not bother you with anything unless there is a real problem and then it is much less annoying than any other I have tried. Further, it does not 'decide' to do a scan just when you need the machine for something important so it does not slow things to a crawl especially since you are still using a Core 2 Duo rather than a newer quad. I hope that you have finally licked your problem but keep us posted.

You have to be a little bit crazy to keep you from going insane.


Report •

#10
April 30, 2014 at 19:56:32
Since there wasn't any available hard drive space or connected external drives I thought maybe drive X: was a ramdrive--a temporary drive carved out of ram by software. I did some searching and it turns out that it's a ramdrive created for 'windows recovery environment'. So it's not a virus.

Maybe it loaded that way after the crash and for whatever reason got stuck in a loop. Something like that sometimes happened with dos-based systems where a particular software needed the system to reboot with different versions of config.sys and autoexec.bat. But if the program wasn't exited correctly it sometimes got stuck in a loop booting the wrong versions of those files.

If it happens again try typing exit and enter and see what happens. Also some people reported that running:

Bootrec.exe /FixBoot

and/or

Bootrec.exe /FixMbr

from the prompt will fix it.


Report •

#11
April 30, 2014 at 21:07:26
Thanks DAVEINCAPS...I'll keep that in mind if it happens again.
I'm still not convinced that it's not a virus/malware just from the way it acts...should it happen again, I'll record everything that I attempt in order to repair and post again as "Drive X".
Thanks again.

Report •

#12
May 1, 2014 at 00:05:20
You're welcome. I know it acts screwy making you think it's malware but I doubt it is. But it would be interesting to have more details should it happen again.

message edited by DAVEINCAPS


Report •

Ask Question