Windows 7 Can't resolve DNS

March 20, 2011 at 20:08:55
Specs: Windows 7
Windows 7 home premium has just stopped being able to resolve dns.
Other laptop on same home wireless network can.
I have it set to obtain dns in control panel.

See More: Windows 7 Cant resolve DNS

Report •

#1
March 21, 2011 at 04:13:29
thanks but that didin't work.
any other suggestions?

Report •

#2
April 28, 2011 at 16:37:34
In case someone else has this problem. This is the second website that comes up for a google search on this and the most recent date of this problem. This is on a Vista PC though:

If you got to START -> type in CMD and enter
then type:

ping www.google.com

it says "ping request could not find host" immediately. But if you type

nslookup www.google.com

it gives you an ip address and if you ping that address it pings fine.

IE will display google by the ip address but not if you type in the domain name www.google.com. And no other domains will show up in IE.

After searching on the Internet for many hours the solution was this:
START -> type CMD and press enter
type:

netsh winsock reset

It should say successful and ask you to restart. After restarting IE in Vista worked fine and ping worked fine.


Report •
Related Solutions


Ask Question