windows 7 cannot read Iomega zip disks

Iomega / Z100usb
October 2, 2010 at 19:44:42
Specs: Windows 7
I found some really old zip disks and an external to run them. The first disk i tried had some very old files of mine on it that i'd long forgotten. not bothering to open them, i tried out the other disks. the rest were blank. When i put the first one back in to copy the files, windows could no longer read it. The drive made the click and hum of not being able to read it, and windows complained "The disk is not formatted." and a "cyclic redundancy check"

What could have happened in that brief time for the disk to become unreadable/unaccessable? It was only a half hour. More importantly, how can i recover what is on the disk? surely it's still there, but i want to suspect that windows messed up how when ejecting it. I've tried some disk repair programs but the computer says the disk wont allow access. I'm open to all ideas and solutions to try to see those old files again. i should have copied them the first time it was still open.

See More: windows 7 cannot read Iomega zip disks

Report •

October 3, 2010 at 06:27:04
You really don't know if you would have been able to copy the files on the Zip drive the first time. You may have gotten the CRC error then too during the process.

I suggest you try a recovery software. Below are a few.

PC Inspector (freeware)
Zero assumption Recovery
The demo is limited
It will only recover 'up to' four folders per run
But you can make multiple runs
not free

Report •
Related Solutions

Ask Question