windows 7 cannot install any programs

Ultimate Windows 7 ultimate 64-bit
January 23, 2011 at 08:21:23
Specs: Windows 7, AMD X4/ 8gig dual
i just installed windows 7 ultimate on a custom build computer msi board, amd x4 8gig ram. It was a barebones kit which i added the ram and sata hd. Everything went fine with the clean install. However in the bottom right corner it says: Test Mode Windows 7 Build 7500.

I can install some programs from cd's or dvd's, but absolutely zero programs from my hard drive. I can transfer/view any file but i cannot install. Gives several errors depending on which program and whether is downloaded or from a cd/dvd or transferred via USB drive from another computer: This File is Corrupt, if i download and run directly from IE it says the file does not have the correct digital signature, one says NSIS Error Installer integrity check has failed. One loads and extracts and then simply crashes. Some of them crash and come up with the windows solution window some don't.

Here's a list of things i have already tried:

Disabling User Account Controls
Disabling Windows Firewall
Disabling Integrity Checks (Com Pr Run As Admin)
Changing EI security settings, Allow almost everything (scripts, active x, ect)
Reinstalling Windows 7 Ultimate
Reinstalling Windows 7 Ultimate (32 bit instead of 64)
Changing Install to Windows 7 Home Basic
Changing Install to Windows 7 Home Premium
Running Windows 7 repair disc
Checked for missing system files (Com Pr Run As Admin)
Run Programs As Admin
Updated/Installed all of Windows Updates
Ran Check Disk
Run Program Compatibility Windows XP
Checked Clock/Time, Tried to change forward and backward
Uninstalled EI 8 and reinstalled

I am %100 sure all these errors are related b/c they all have the common theme of not letting me install hardly anything. After 3 days of trying i finally was able to install firefox and winzip after transferring them from another computer via external hard drive and "run as admin" but i cannot install: Avast, AVG, Sandboxie, Flash Player, DivX, and a host of other programs from hard drive or cd/dvd or external hd. I have visited countless message boards and microsoft support and tech support and i have found ZERO solutions. I haven't even found a message board yet that anyone said that their problem was fixed at any point, so im not even sure it is fixable. However it seems to me like this is a Registry Problem or possible a corrupt installer file. But im confused as to why i can install some of the time from my cd/dvd player but not from my hard drive. I know it isn't just the hard drive b/c i can't install many of the programs from my cd/dvd player either, and i also installed windows just fine to the hd and i can run/view all files and installed programs, so hard drive failure/compatibility seems unlikely. I have checked all drives and found no problems or further updates. The computer is not overclocked and functioning fine otherwise.

I am not IT but i have worked with computers and windows extensively and i can program a little in .net but i just don't have the time to check each file/registry. This is my 2nd time installing windows 7 (different copy) on another computer (BB gateway) and that install went fine and no program issues. It could be i have a bad copy of windows, it just seems odd that some programs install and some don't. They all run without a hitch once installed.

IF ANYONE OUT THERE HAS HAD THE SAME PROBLEM PLEASE COMMENT ALONG WITH ANY SOLUTIONS YOU HAVE FOUND OR HAVE EVER HEARD OF BEYOND WHAT I HAVE ALREADY TRIED@!@!!!!!


See More: windows 7 cannot install any programs

Report •

#1
January 23, 2011 at 12:08:32
Open a cmd window with administrator rights and run this command:

Bcdedit.exe -set TESTSIGNING OFF

Reboot the PC and the test mode should go away.

Try this solution I found.


Report •

#2
January 23, 2011 at 14:02:10
thanks that solved the smallest of those problems but thanks anyway, now the text is gone but i still cannot install any programs.

Add to list Disabled Digital Signatures Requires through cmd and upon startup. No change.


Report •

#3
January 23, 2011 at 14:27:48
i finally got it fixed!!! i downloaded Wise Registry Cleaner Free from CNET on another computer, tr to USB ext hd and then connected to current computer, run as admin, thank heavens it worked and when i ran the scan and fix, i could now install all programs without a hitch. now i just hope i didn't screw anything up when i was trying to fix it. WOOOHOOO!

Report •

Related Solutions

#4
January 25, 2011 at 20:36:25
this problem repeated after it was resolved, b/c windows updates turned back on windows user account controls, if you change windows user account control settings to the lowest level this should take care of the issue if it reappears after repairing your registry.

Report •

#5
August 20, 2011 at 08:13:00

to load most programms as administator you need to have a user acount.
sort out the easy things first. good luck.
ken

Report •

#6
August 20, 2011 at 08:50:12
download a genuine win7 sp1 from here, install by doing a full format of the drive from the advanced tab.i would suspect that your copy is damaged.
activate as soon as installed, i suggest MSSE rather than a 3rd party AV.

if you still have issues using this ISO i would suggest a bad memory stick or a bad sector on your drive. try 1 stick of memory at a time in each slot to verify a bad stick or a bad slot.
create a second partition and install onto the second partition, this will help verify if the 1st partition has bad sectors..

i hate computers!
but cant help myself....


Report •

Ask Question