Solved Windows 7 BOOTMGR is missing - Stumped.

September 27, 2011 at 10:20:07
Specs: Windows 7, Pentium Dual core / 1 GB
I went to start my computer, and received the error "BOOTMGR IS MISSING".

I tried to repair the installation using the Windows 7 DVD, no luck, same message.

I tried to completely re-install Windows, no luck, after first reboot it gives me same error. (Tried many times).

Tried running a memory test from the windows 7 DVD, when the computer rebooted the test failed to start (tried multiple times).

I tried the disk on another computer, it installed windows 7 fine.

I tried installing ubuntu from bootable USB flash, worked great. No errors, no signs of trouble and I've been using it for days.

I tried installing windows 7 from USB flash - same error.

I've tried booting into Acronis True Image boot disc to recover my last backup, but it seems as if the boot disc is not compatible with my Acer, it boot-loops. Tried my bootable acronis USB - same problem.

At this point I'm thinking either RAM or the HDD is bad, but I don't get it since Ubuntu has been running great. Any input on this would be very helpfull, or suggestions on bootable utilities to test my hard drive or memory.



See More: Windows 7 BOOTMGR is missing - Stumped.

Report •

#1
September 27, 2011 at 18:35:47
✔ Best Answer
Memtest86 is a downloadable utility ISO image that you burn to CD which is independently bootable and does a great test on your memory.
Each hard drive manufacturer offers a similar utility to download from their websites for their hard drives that would be the best test and possible repair (for minor problems) for your hard drive.
Windows 7 might just be directed to use only (unless unavailable) a certain address range on your hard drive for it's boot files, and if that is where the errors are then 'repairing' them or marking them as unusable through their utility may just fix things.

You have to be a little bit crazy to keep you from going insane.


Report •

#2
Report •

#3
September 28, 2011 at 03:07:55
Hi,

To fix BOOTMGR missing file problem open your antivirus software program and run a full scan on your computer.

When the scan is complete delete all quarantined and infected files.

Then insert the Windows 7 installation CD into your computer’s drive and restart the computer.

After the reboot open the command prompt and type fixboot.

Then press ‘y’ when a pop up box appears asking you for confirmation.

Then it will automatically solve the boot problem and you should be taken to your desktop.

http://social.technet.microsoft.com...


Report •

Related Solutions

#4
September 28, 2011 at 06:52:01
Some BIOSes have an anti-virus feature where they prevent writing to the boot sector of the HDD. Make sure that's disabled before performing any fix.

How To Ask Questions The Smart Way


Report •

#5
September 28, 2011 at 07:09:57
Thanks everyone, I'll look into the bios settings, and run a hard drive error checking utility.

I performed the memtest x86 built into Ubuntu, and it's a wonder the system has run at all on Ubuntu. I had a defective stick of memory in it about a year ago which prevented the system to run, I removed it and the system ran fine. That left me with 1 GB. When I ran the test yesterday it found over 8,000 errors. I've ordered some more RAM so I will start there.


Report •

#6
September 29, 2011 at 02:52:14
try those sticks in different slots and run the test, it may also be that your slots are dirty or just bad.

i hate computers!
but cant help myself....


Report •

#7
October 6, 2011 at 08:18:16
Thanks guy, I replaced the memory, and the new memory passed the test with flying colors. I also tested my hard drive with no errors.

Report •

Ask Question