Windows 7 Autoexec.bat read only

September 22, 2010 at 10:19:52
Specs: Windows XP
I'm trying to add Set Station=3461
Set foxproswx=-t to the autoexec.bat file in Window 7.
I've tried it though the CMD, at the C: I type edit Autoexec.bat and it says it's an unrecognized command. I type DIR /P and I can see the Autoexec.bat in the directory of c:.
If I type edit Autoexec.bat at the default C:\users\Chris I get a blank autoexec.bat file but the one I want to edit has a rem already in it. So this isn't the correct file.
I go to Run and sysedit and can't save the changes.
I've also tried Searching for Autoexec.bat, right clicking on the autoexec.bat file and selecting edit. It opens but won't let me save. it have read write checked of for properties. I can't add any more rights even as logged in a admin. Any ideas?

See More: Windows 7 Autoexec.bat read only

Report •

September 22, 2010 at 11:31:52
You are going about this the wrong way. With older systems it was common practice to set environment variables in the autoexec.bat file. In Windows 7 this file is nothing more than a relic of the past, maintained only for compatibility with old programs.

This is how it is done in Windows 7:

Report •

September 22, 2010 at 12:03:27
For a better understanding of Autoexec.nt & Config.nt in Windows 7, read THIS.


Report •
Related Solutions

Ask Question