Win7 x64 Can't read mounted BluRay ISO (UDF)

Intel / Dq3510j
November 11, 2010 at 06:02:10
Specs: Microsoft Windows 7 x64, 2 GHz / 4025 MB
I have a Windows 7 Ultimate machine. When I mount an BluRay ISO to a virtual drive, the drive shows nothing, and I get an error if I try to browse it saying it cannot read the disc or it is a format that can't be read.

To make this more of a mystery, when I try the same actions on my other Windows 7 Ultimate machine, the image mounts fine, can be browsed, and played with the appropriate software.

I have tried installing Windows UDF-drivers update 6.1.7600.16435 Win7-32-64-bit but no dice.

Has anyone else had this problem? I have scoured the net and found nothing.

Cartman


See More: Win7 x64 Cant read mounted BluRay ISO (UDF)

Report •

#1
November 11, 2010 at 22:51:05
are you using the windows center on both machines?

what iso program are you using?
do you have all the updates?

i hate computers!
but cant help myself....


Report •

#2
November 12, 2010 at 03:40:15
Using Power DVD ... not using Media Center. I have tried 2 different programs to mount the image: VirtualClone Drive and Daemon tools lite. Both say the image is mounted but nothing shows in the virtual drive.

On my working PC, either program mounts the image as well, and windows also lets me view the contents of the drive ... and PowerDVD works just fine. I've rarely ever applied any updates to the working machine so you would assume that would be the one to have problems.

The only applicable update I could find to get Windows 7 to read UDF (which I thought it did out of the box) was Windows UDF-drivers update 6.1.7600.16435 Win7-32-64. Are there any other updates you know of that would apply?

Cartman


Report •
Related Solutions


Ask Question