Solved win 7 clock keeps reverting to 1899 or 2099

August 19, 2012 at 07:03:29
Specs: Windows 7, Intel i7/12Gb
I rarely turn my computer off but the clock occasionally reverts to 1899 or 2099. I check the cmos clock and that date is correct. Something is triggering the change perhaps virus? MalwareBytes has not registered it. so I don't know what to do :-(
I am considering a reformat but obviously I prefer not to.

See More: win 7 clock keeps reverting to 1899 or 2099

Report •

✔ Best Answer
August 23, 2012 at 12:26:07
Then try clearing the CMOS by using the jumper or removing the battery. Either of those must be done while the computer is unplugged.

If that doesn't work then you may need to update the BIOS.



#1
August 19, 2012 at 07:52:56
I am pretty old but even I didn't see computers back in 1899. :)

I assume it is some issue with the real time clock. Either the battery or a slight fault is causing it.

I doubt a reformat would help. Set time to NTP and maybe forget about it.

Google is evil


Report •

#2
August 19, 2012 at 09:32:51
Interrupting power to the computer makes the CMOS battery hold the user adjustable BIOS settings. Your CMOS battery may be weak or failed. Normally when that happens the date will revert to the date of the included BIOS version but I suppose the issue could still be the CMOS battery.

Open the link below to see what the CMOS battery looks like.

https://www.google.com/search?q=pic...

I also doubt this is a Windows issue. However, boot to the BIOS (setup) before changing the battery after you have interrupted power to the computer to see if the date is correct.


Report •

#3
August 20, 2012 at 03:29:29
thank you both for answering.
I may have not made myself clear but when the time change occured I went into CMD and checked the CMOS time and that showed the correct date. BTW what is NTP? I am in the GMT zone

Report •

Related Solutions

#4
August 20, 2012 at 08:15:26
Newer versions of Windows should update the date/time when in Windows. That has nothing to do with the real time clock in the BIOS.

Report •

#5
August 20, 2012 at 09:18:23
See this for RTC http://en.wikipedia.org/wiki/Real-t...

I can't assume how your computer works internally. Some battery and some device is providing a genuine clock that is not supposed to stop on power off. The OS may take from that or another calculation to provide what you see.


The issue is the date you posted. It can not be that date by any known battery fault. If you meant 1998 then maybe clock battery.

Second issue is, do you need to fix it? Maybe. Maybe not.

NTP is network clock that should allow your computer to adjust to the correct time when connected to the (usually) internet. If you set it in clock settings and you don't have any other issues then why fool with the issue. Don't fix what ain't broken. Windows 7 clock settings have a choice for internet time. Other ways to set clock too.

If you have other issues then you may need to fix this. The general assumption that you have a small battery either visible as such or contained in a chip is going bad.

Google is evil


Report •

#6
August 21, 2012 at 15:44:55
Date wise the most that windows 7 can go back to is 1980. The lowest limit should be 1980 to the high of 2099. The lowest year that you can reach in the bios is probably the date of the originally bios version year even if it has been flashed to a newer version. In my case it is 1999.


Report •

#7
August 22, 2012 at 03:05:30
I know it shouldn't show 1899 but it does! Next time it happens I will attach a screen shot

Report •

#8
August 22, 2012 at 06:04:23
It happened again today at 13:00 GMT and it reverted to 30th December 1899 and the time reverted to 00:00
I took screenshots but there doesn't appear to be a way to attach any screenshots to this forum. However, take my word for it, regardless of previous comments, you can go back to 01/01/1900 manually, so why it flips to 30/12/1899 is anybody's guess.
I believe this time reversion seems to happen at the same time each day (13:00GMT) I did set the clock manually to 12:59 to test my theory but the reversion did not occur so back to square one:-(
I am wondering if I have been hit with a Trojan.

Report •

#9
August 22, 2012 at 07:03:38
Just for clarification, this is the System Time itself,
not a program like a backup scheduler or
widget that displays the System Time, correct?

There is a reported problem with scheduling a Backup:

http://www.overclockedtechies.com/2...

Unfortunately, no solution is offered.

MIKE

http://www.skeptic.com/


Report •

#10
August 22, 2012 at 07:38:45
hi Mike, this is system time

Alan


Report •

#11
August 22, 2012 at 08:30:33
Best I can think of at the moment is to check the Task Scheduler
and see if anything is kicking off at 13:00.

Could give you clue as to where the problem is.

MIKE

http://www.skeptic.com/


Report •

#12
August 23, 2012 at 07:10:40
I checked the scheduler and could find nothing that indicated a task at 13:00 GMT. Incidentally, I waited 'til after 13:00 today to see if it occurred again. It did!
I made an error earlier in this discussion when I said the CMOS time wasn't affected. It was. i.e. CMOS time indicates the same date i.e. 30/12/1899.
Is this a chicken or egg problem? If it is a battery issue then I would expect the date to revert to something close to our timeline.
I Checked the the events log and it showed this message:
- System

- Provider

[ Name] Microsoft-Windows-Kernel-General
[ Guid]

EventID 1

Version 0

Level 4

Task 0

Opcode 0

Keywords 0x8000000000000010

- TimeCreated

[ SystemTime] 1899-12-30T01:00:00.010000600Z

EventRecordID 80409

Correlation

- Execution

[ ProcessID] 2940
[ ThreadID] 2944

Channel System

Computer Alan-PC

- Security

[ UserID]

- EventData

NewTime 1899-12-30T01:00:00.000000000Z
OldTime 2012-08-23T12:00:05.741305000Z

does this give any clue?


Report •

#13
August 23, 2012 at 09:40:19
You are correct that the BIOS should not show a date that old. Obviously there is some sort of corruption in the BIOS.

Have you tried resetting the date and time in the BIOS? Be sure to save upon exit.


Report •

#14
August 23, 2012 at 10:18:47
I have already tried that. each time this 'reversion' happens I reset the system clock by setting the CMOS clock

Report •

#15
August 23, 2012 at 12:26:07
✔ Best Answer
Then try clearing the CMOS by using the jumper or removing the battery. Either of those must be done while the computer is unplugged.

If that doesn't work then you may need to update the BIOS.


Report •

#16
August 28, 2012 at 07:27:55
I updated the CMOS and, fingers crossed, it appears ok now. Many thanks to you and all the other contributors to this thread :-)

Report •

Ask Question