W7 X64 IE8 X86 no longer load (IE8 X64 is OK)

August 30, 2010 at 14:47:03
Specs: Windows 7 ultimate 64bits, E6600/2gb DDR2
I have a nearly fresh (1month) Windows7 installation, and I installed it quite often so I usually do this right with every drivers and such. I have a up-to-date Kaspersky antivirus with no problem detected.

I usually use Firefox so I didn't realize this until now, but my Internet Explorer x86 just won't start, it does nothing. If I start the x64 version though, it works fine. It asks me if I want to "restore" my previous session, which open a new window on the home page for every time I tried to start the x86 version.

I know my way around computers, I just want a hint of where to start to look for the cause of the problem.


See More: W7 X64 IE8 X86 no longer load (IE8 X64 is OK)

Report •

#1
August 30, 2010 at 15:51:06
You're running the 64 bit version of Windows 7. You can't use 32 bit software.

Report •

#2
August 30, 2010 at 16:19:44
That's totally wrong, search it up. Plus, both versions are automatically installed when you install x64, and it worked before as it still does everywhere else around me.

Report •

#3
September 1, 2010 at 14:20:31
This is a bump

Report •

Related Solutions

#4
September 2, 2010 at 07:03:50
You are correct. Windows 7 64 bit comes with two IE8 versions.

1. The executable for IE8 32-bit is located here:

C:\Program Files (x86)\Internet Explorer\iexplore.exe

2. The executable for IE8 64-bit is located here:

C:\Program Files\Internet Explorer\iexplore.exe

Open Run and navigate to the IE8 32-bit version and run it. Does it load?

i_Xp/Vista/W7User


Report •

#5
September 2, 2010 at 15:01:50
No it don't I run iexplore.exe and nothing happens. The shortcut links directly to the file anyway.

Report •

Ask Question