USB30 external HDD keep disconnecting in Win7

November 13, 2010 at 07:37:26
Specs: Windows 7 64bit, e8500 3.15ghz 4gb ram.
I've just installed a USB 3 PCI Express card on Windows 7 Pro 64 bit. I've a 320gb sata drive in a USB 3 caddy. The caddy works ok plugged into a USB 2 socket, but is temperamental to say the least when it's plugged into a USB 3 one. Whenever I try copying from it, it never finishes the job, and is forever disconnecting, and reconnecting soon afterwards. In device manager I get a code 10 (device won't start) each time there is a disconnect. I don't whether it's a compatibility issue or a hardware issue, and have never had problems like this with any other "new" developments.

See More: USB30 external HDD keep disconnecting in Win7

Report •

November 13, 2010 at 08:33:55
It's not a compatibility issue or a hardware issue. Rather, Windows 7 still isn't yet ready to support USB 3.0.


Report •

November 13, 2010 at 17:55:30
eSATA would probably have been a better option. I believe that your motherboard and windows would treat it just like any other SATA port and you usually only have to add a port and plug it into an existing SATA port and probably an auxiliary power port.

You have to be a little bit crazy to keep you from going insane.
If all else fails, read instructions.

Report •

November 14, 2010 at 03:31:19
Thanks for the replies so far.

As I understand it, Windows 7 SP1 will be providing proper support for USB 3, so we'll all have to wait and see (January 2011?).

As for esata, I've already got that, but was drawn to the higher USB 3 speed. I'll go back to using my external esata drive until Microsoft wakes up.

Report •

Related Solutions

November 14, 2010 at 13:01:33
Did any drivers come with the card? I just assembled a computer using a board with USB 3.0 ports. The installation CD came with drivers for USB 3.0 in Windows 7.

So, I am guessing you need additional drivers. If not on a cD then try the manufacturer's site.

Report •

November 15, 2010 at 02:12:31
Yes, the drivers did come with the card.

For some mysterious reason, the drive doesn't connect anymore (today anyway), and the only thing that I did, was defrag it, even though it wasn't that bad. The Gremlins are out to mess with my head.

Report •

November 15, 2010 at 05:42:42
Look for the drive in Disk Management.

Report •

December 20, 2010 at 15:24:05
I've got the same problem. PCI-e Renesas USB 3.0 Host Bus Controller and tTB Samsung F4 in a USB 3.0 enclosure with power supply. (OS= W7-64)

Drive is recognized, but when used (read / write) dis- and reconnects within seconds. After switching off USB 3.0 Power management functions it seems to take a bit longer before the disconnects take place. But the still happen. Impossible to copy a file >200MB. Replacing the cable with a USB 2.0 (still on 3.0 HBA) one reduces speed, and disconnects are gone...

Report •

December 20, 2010 at 15:29:54
Sounds like USB 3.0 growing pains. These things happen to all new standards at first.

Report •

December 22, 2010 at 04:25:49
It's temperamental to say the least. I bought a different enclosure, thinking that the un-branded first one might not be up to the mark. The 2nd one connected OK to my W7 HP laptop, but only if it was connected before power-on. It wouldn't detect it if it was connected afterwards.

On my desktop, I get code 10 when I connect the new enclosure.

With the original enclosure, it's the other way round.

The laptop has a Silicon Express USB3 express card adapter, and the desktop a Silicon Express PCI Express card. They both have the latest up to date Renesas/NEC drivers installed. I got these from:

I'm now assuming that the drivers aren't quite right.

Report •

January 27, 2011 at 10:52:18
your not alone..... i have no problems with my usb 3.0 drive but my esata drive keeps sleeping and disconects. im sure its the green WD drive doing it. my usb 3.0 had been disconecting but since i upgraded my psu its not been an issue. my usb 3.0 card
has a dedicated power molex conection.
as for esata any way there is a way round this fault :

i have just started using it and so far no disconection, running windows 7 64bit

check it out, its a free program and it writes a small file to the hard drive at an interval set by the user.

good luck, what drive is inside your usb 3.0 enclosure ?
and does it have a molex conection on the usb 3.0 card ?

Report •

January 31, 2011 at 14:56:01
I've never had any connection problems, or any trouble with any esata drives.

My USB 3 PCI express card has a molex connector on it, and I've got a WD 320gb sata drive inside the enclosure.

Even after the latest driver update, I can still only get one machine to detect the drive, even though both USB 3 interfaces are made by Silicon Express, using the same chipset and the same drivers.

When I do connect now, it stays connected, which is progress at least.

Report •

February 23, 2011 at 06:44:39
Needless to say, the Windows 7 SP1 that I downloaded, and installed, made no difference whatsoever to the crock that is USB 3.

Could this problem be something to do with Intel's chipset utility?

Report •

February 23, 2011 at 19:39:38
See if the card manufacturer has a support site, they or someone may have solved the issue, they may soon update the driver again, or they may be willing to replace the card with a newer updated version. If they are selling it, they must assume people with Windows 7 and all types of motherboards might purchase it so it needs to work with all combinations.

You have to be a little bit crazy to keep you from going insane.

Report •

February 24, 2011 at 06:57:38
Silicon Power, the manufacturer of the PCI and express card adapter, has nothing on its website apart from advertising for these items. I contacted them anyway, and after replying to their first email to me, I'm waiting for them to get back to me. USB3 is a joke at this stage, because it just isn't universal, no matter what people might say. With different enclosures acting differently between machines, it really is a waste of time. Everything that I've got operates with the same chip, so I would expect some success.

When attaching an enclosure, sometimes I get a message telling me that the drive needs formatting, and when I tell it to format it, I get another message telling me that it can't be formatted because it isn't there! ARRRRRRGGGGGHHHH!!!!!

I see that all kinds of USB3 stuff is available now, including hubs, flash drives etc.., but I'm not handing over any hard-earned cash for an ornament. I even bought a USB3 cable that didn't work, and it has been known that the wiring on some of them is wrong.

Report •

February 24, 2011 at 09:30:06

I found this on the Intel site.


Report •

February 24, 2011 at 09:52:33
I examined the contents of the latest chipset utility information file, and there's no mention of USB3 anywhere, in fact there's mention of everything but. Some people are suggesting that Intel is holding back on USB3 support because they want to take the world by storm with Light Peak. That's what made me think that Intel could be the villain responsible for the USB3 problems, but it could anything or anyone.

Some Light Peak info:

Report •

July 7, 2011 at 05:14:52
My Mukii TransImp USB3.0 external casing is more than tempermental. When connected to USB2.0 its fine, but depending on how I play around with driver and firmware (and I've really tried it all) I get either no detection, the 'detected' sound, but no detection, connect/disconnect immediately, connect/disconnect please format - which can't format and says the drive is disconnected, and the 'looks like its working' connect which disconnects the second I try to transfer a file bigger than 100MB to or from the drive. Inside the casing I have a 'FUJITSU MHW2160BH PL USB' 2.5" laptop drive of +- 160GB. I've tried the latest three driver and firmware updates/installations in every combination and tried all the power state management solutions. They really don't make any difference. The USB3 drivers which came with the Intel P67 board are also installed, no avail. Any ideas anyone?

Report •

July 7, 2011 at 09:04:36
I've made no further progress with mine, and just keep updating the drivers and firmware as they become available. Mine still doesn't keep disconnecting, but I can still only use it on my desktop as USB 3. It still won't work on my laptop USB 3 connection.

Have you tried updating to the latest firmware on the French site? The latest one's dated 17th June.

Report •

Ask Question