USB to parallel adapter issue

Citizen / 200gx printer
July 28, 2010 at 07:22:50
Specs: Windows 7
I have the following printing issue that I would like to resolve ASAP.

I have recently bought a new pc with Windows 7 Ultimate 64-bit Edition. This pc does not have any parallel or serial ports installed i.e. I can only use USB ports for printer, mouse etc. My old pc is running Windows 98 OS. I also have an old dot matrix Citizen 200GX printer.

Because Windows 7 doesn’t come with a printer driver for the Citizen 200GX printer I tried using other Citizen drivers on my old Windows 98 pc and found the Citizen GSX-190 printer driver to be compatible with the Citizen 200GX printer and worked perfectly using both the black and colour ribbon without changing any of the dip switch settings.

Because of this, I found and installed the Citizen 190-GSX printer driver on my new Windows 7 pc. I tried doing a test print on my new pc using a USB to parallel (centronics) printer adapter by going into Properties in the GSX-190 printer driver setup in Control Panel but this didn’t work. I haven’t been able to print anything from any other program also.

Is anyone able to suggest a solution to this? There are 2 main programs I am trying to print from – a Microsoft program Visual Foxpro 7 and secondly from a program called ZTree for Windows (based on Xtree Gold – is a file manager program).

I would greatly appreciate help in resolving this ASAP. If not the only other solution I am considering is to buy a cheap Windows XP pc that uses a parallel port and not a USB for printing and has a printer driver for the Citizen 200GX. However, I am hoping that there is a cheaper solution to this problem.

Thanks
Kevin


See More: USB to parallel adapter issue

Report •

#1
July 28, 2010 at 08:02:54
Stick with your original post. Duplicate posting can result in both being removed.

http://www.computing.net/answers/wi...


Report •

#2
July 28, 2010 at 08:51:39
I have finally resolved this issue. When using the USB to parallel adapter, I forgot to change my printer port from LPT1: to USB001. This has fixed my printing probelms.

Thanks


Report •

#3
February 18, 2011 at 17:35:36
Hi Prof890.
I have a citizen 200gx and i conected with my lptop whit usb to paralel centronics cable.
i changed to usb001 port to, and dont working.
i think the problem is the position of the swiches inside the machine.
there are two swiches whit 8 pin both and i testing change the position of the pins .
please could yo help me, and said me the position of the pins in the switches.
the switches are together the port of the printer.
sorry and tanks very much.
sorry for my english

Report •

Related Solutions

#4
February 20, 2011 at 21:05:03
Create your own post and put it in the hardware section.

You have to be a little bit crazy to keep you from going insane.


Report •

#5
February 21, 2011 at 04:44:25
Hi mtm001,

Perhaps you had better post in the hardware section so you don't offend anyone. I will then try and help you.

Regards

PS: I did not have to make any changes to the position of any switches when plugging my printer into the USB port. You shouldn't need to do this.


Report •

#6
February 21, 2011 at 05:51:52
You are certainly welcome to answer, but many will not answer 'hijacked' posts as well as people interested in helping with hardware issues, even obscure ones will be looking rather than here.

You have to be a little bit crazy to keep you from going insane.


Report •

Ask Question