USB mouse on HP laptop stops working

April 25, 2010 at 02:07:42
Specs: Windows 7
hello all,

I have a weird problem these days. I am using an HP Pavilion laptop running win 7.

My mouse was working fine until I connected my ipod nano gen 2. When I did that it continued to glow red, but did not work. restarted - nothing. restarted disconecting everything except the mouse - again nothing.

Then I connected another mouse and it worked fine. Until I connected the ipod again. Disconnected the ipod, restarted - the same story repeated itself. When I connect it to a different USB port though it flickered red a few times and then it stoped completely.

Windows said "usb device not recognized".

When I connect it back to the usb port it was connected previously, even before the ipod was connected, it again glows red, but does not work. Windows is silent :) ...

Please advise if anyone knows how to fix this.

Thanks


See More: USB mouse on HP laptop stops working

Report •

#1
April 25, 2010 at 02:41:40
just like an i-anything, nothing but problems..i cant see its anything to with your mouse's, they work without the ipod, or untill the ipod is connected so it pretty obvious the ipod is the problem
you could connect your mouse, open control panel, device manager and uninstall the mouse, then do a scan for hardware changes, by right clicking on the upper most icon for your computer in device manager, it should find the attached mouse and then install the drivers..

i hate computers!
but cant help myself....


Report •

#2
April 25, 2010 at 02:49:59
When I connect the mouse the the first usb port, the one that it glows red when connected to, it doesn't appear at all in the device manager as if it is not there.

When I connect it to the second usb port it appears as an unknown device under universal serial bus controllers. I do what you suggest, but then appears a msg device driver software was not successfully installed ...


Report •

#3
April 25, 2010 at 12:07:32
Got help and problem solved

Here is how for anyone who may experience similar thing:

Shut down
Remove mains lead
Remove battery
press and hold power button for 30 seconds
refit battery
reconnect mains lead
Boot laptop
retry USB device


Report •
Related Solutions


Ask Question