Upgrade Acer W7 Microphone not working, WHY??

Acer Aspire 4810tz-4696 notebook
May 16, 2010 at 10:12:49
Specs: Windows 7

I've got an Acer laptop model Aspire 4810TZ-4696 and I recently got from Acer the new Windows 7 Upgrade (used to have Vista). After upgrading everything works correctly except for my microphone. In Audio devices under "Recording" the microphone(Realtek high definition audio) appears to be all ok, it's default device with a green check mark, it's not on mute and volume's at max. It says the device is working properly and I've also checked for updates for the driver which says no updates available. So apparently it should work, yet when I try calling with skype it says "problem with recording device" and when i test the microphone on skype it says the microphone seems to be working fine yet when i try test recording on skype nothing happens.
When I try "sound recorder" on the pc it says "an audio recording device cannot be found" and when i try "set up a microphone" it says "make sure your audio hardware is working properly and check audio config ect...".
I've tried running "find and fix audio recording problems" but it doesn't detect any problems.
I've checked various topics on the issue but no one seems to have the same exact problem I do.
I've also used Windows 7 Upgrade Advisor which said there are no compatibility issues.

Does anyone know what the problem is and what can be done to fix it?

Any kind of help will be very much appreciated since the issue is urgent.


See More: Upgrade Acer W7 Microphone not working, WHY??

Report •

May 16, 2010 at 16:02:43
have you uninstalled/reinstalled the driver since your upgrade? And have you checked on the acer website for any specific windows 7 audio drivers

It could just be that windows 7 did not upgrade the drivers and is still using incompatible vista one's, or (more likely) updated the drivers with "microsoft compatible" one's that don't entirely work with your soundcard

As I dont have this laptop, that is all I can really think of atm
Hope this helps!

Report •

August 14, 2010 at 07:26:29
I've had the same issue with my Acer Aspire 4810TZ after Windows 7 upgrade. The microphone simply would not respond. And when using Skype it'd read, "problem with recording device" and immediately terminate the call. When I'd go and check the microphone under Control Panel > Hardware & Sound > Sound > Recording, the Realtek microphone listed there was in fact selected with a green check mark (correct setting, it was enabled) but it would not respond to sound; the sound level bars were unresponsive. After various attempts to try to find a new driver through Realtek's website (which is horrible btw) and through several fake driver download sites (frustrating), I eventually called Acer Customer Support (mixed reviews on that in the past). Acer was able to help me very swiftly. Here's what you do. It fixed it instantly. (1) Uninstall Skype (2) Go to Windows Start Menu (3) Right click on Computer in the right hand menu (4) Select Properties from the drop down (5) Click on Device Manager in new window (6) expand the menu for Sound, Video and Game Controllers (7) Right click on High Definition Audio Device (or Realtek audio/recorder if it says that) (8) Select Uninstall (9) Select Restart from the pop up window (10) Allow the computer to restart (11) When the Acer reboots the device manager bar will notify you that it's downloading a new driver -- this is replacing the one you just deleted; it does this automatically (astonishing since I couldn't find one myself on the web) 11) Now go to Start Menu again 12) Select Accessories from the start menu, at the very top 13) Select Sound Recorder 14) Test here if it's recording your voice, at this point, it should 15) Quit out of that 16) Reinstall the latest version of Skype 17) When Skype reinstalls it will say, "Found new recording device, click to accept" 18) Click "OK" 19) Voila. You're up and running again.

Report •

December 12, 2010 at 08:20:20
I have an Acer Aspire 5740G which makes a very poor audio recording. I have also tried Audacity and again the same lousy recording - same with Windows Media player too. The computer uses Windows 7. Nothing is muted - I don't know what to do - please help

Report •
Related Solutions

Ask Question