System restore & add/remove not working!

August 8, 2011 at 22:51:35
Specs: Windows 7 Ultimate 64, Pentium E5400/2GBx2 DDR2 800Mhz
I have been using Windows 7 Ultimate 64 bit with a Western Digital Cavear Green 500GB as the primary hard disk with three partitions and windows loaded on it, and another WD 250GB as secondary. I am using Norton Internet Security 2011 and the usual MS Office 2010 suit, codec pack etc.

My problem is, for sometime now I have noticed that system restore hasn't been working and because I do not use it I didn't pay any notice to it. But now, since yesterday I was trying to remove a program that I no longer use but found myself unable to open the Add/Remove Program from Control Panel->Add/Remove Program and appwiz.cpl command doesn't work either. Whenever I type the appwiz.cpl command at RUN dialogue box, it appears as thought it would be opening but then seems to subside again.

Moreover, my system told me to install an antivirus though Norton Internet SEcurity 2011 is fully working and is updating regularly! And also, the 'network cable disconnnected' sign/icon or whatever appeared even though my network connection/internet broadband connection is perfectly fine.

I have tried sfc/scannow and system integrity seems fine. Intalled malwarebytes, updated and ran it but of to no avail. I'm simply at a loss. What could possibly be wrong with my windows? I am on the verse of a complete system reformat!

I have asked questions in this site before from time to time whenever I'm desperate and this is definitely one of those times. So, I'll thank you guys in advance for your suggestions and advices.

Ignorance Is Bliss!


See More: System restore & add/remove not working!

Report •

#1
August 8, 2011 at 23:37:37
create a system image, if you havent already.
run disk check and check to attempt to fix files and also check for damaged sectors.it will ask to set a check for next boot, do so and then reboot from the reboot tab.
this check will take a long time on a large drive, once complete,
install your image on another partition, run from the second partition, just to verify that your not having disk issues work on either partition to see if you can fix the error, if not i would just go for a save files, full reinstall and drive format.
dump norton for MSSE, and malwarebytes.
sounds like a harddrive issue, or infection, however you should also run a 24hr memory test, just to be sure

i hate computers!
but cant help myself....


Report •

#2
August 9, 2011 at 00:00:40
Thanks for the prompt reply. Will do as suggested. And...oh, I forgot to mention, the other day I downloaded a WD Data Lifeguard Tools and ran it on my primary HD (500GB WD Cavear Green) but it failed to complete the quick test, then ran a thorough test to see if it can fix any bad sectors or errors but it fails to fix or repair. So I think your suggestion of a bad hard disk is probably right.

So then, if I create a system image and then do a complete reformatting or wipe clean of the hard disk (the 500GB WD one) would it be possible to restore the image on a new partition? And would I be able to recover whatever bad sectors or errors in the said hard disk thereof?

Once again, so grateful for your suggestion and looking forward to more. :D

Ignorance Is Bliss!


Report •

#3
August 9, 2011 at 18:46:24
It sounds like a hard drive problem but sometimes your memory can fool you so run the Memtest86 completely through all tests. NO errors are acceptable with your memory. I have not found that more than one run through has ever been needed to find a bad stick of memory but there might be some errors that will show up under certain conditions (which is why they have as many different types of tests) so you may want to give it a try. If you get ANY errors or your system freezes, stop it (no need to proceed) and retest with one stick at a time to find the bad stick or replace the pair together. I have found that if you purchased a matched pair the manufacturer will generally replace both if one is bad and most memory is warrantied lifetime if you purchased separately but if it came with the system, the system mfg may only cover you for a year.
Once your memory is settled and confirmed working or replaced, repeat the hard drive test.
If you need to replace the hard drive and do not have a recent or complete back up of your files, boot to a Live Linux Disk to try to access as much of your files you can to save, then just reload clean on a new hard drive, install drivers, etc.
Use Avast or MS Security Essentials NOT Norton. They are better and both are free.

You have to be a little bit crazy to keep you from going insane.


Report •

Related Solutions

#4
August 11, 2011 at 05:01:36
Thank you for the suggestions.

I have run memtest for about 20 hours with no errors, backed up all my files and completely reformatted the WD 500GB and installed MS Security Essential. Now everything seems to be working.

But yet another problem arose.

Now I find myself unable to get the Windows Experience Index score. I have run the test, it completes without any errors but at the end it says "The Windows Experience Index for your system could not be computed.
Cannot complete assessment.
The assessment or other operation did not complete successfully. This is due to an error being reported from the operating system, driver, or other component.

I have googled for this particular problem, and there are many suggestions but none of them works for me. I have run winsat formal -v command from CMD and tried to delete .xml file from the DataStore folder but there are no .xml files saved there! So, I'm yet at a loss again.

When I run the winsat formal command, every test runs as it should be but just when it needs to load the result it says something like (or something to that effect) "..xml files cannot be loaded..or there's an invalid character..."

I would be extremely grateful if anybody could once again help me with this problem.

NB: It seems that as soon as you've rectified a problem another problem crops up! And though it is frustrating I am however grateful for the experience and knowledge gained from them. :D

Ignorance Is Bliss!


Report •

#5
August 11, 2011 at 05:21:37
1st, if your drive does have bad sectors, or is failing you will constantly get differing errors, you could try creating 2-3 partitions on the drive, and installing win 7 on each partition, if its only a small amount of damage it will only affect that OS that uses that damaged sector..you can then use the working OS and use the other partitions for storage.

or
you may need some drivers for your motherboad chipset, go to the mobo system manufacturers site and look for mobo chipset drivers, win 7 updates or vista drivers, you may even be able to use the originals which you probably have a on cd.

it may also be that your image is not good due to the damaged sectors, try opening a cmd box as admin and run SFC /scannow.

i hate computers!
but cant help myself....


Report •

Ask Question