Streets & Trips GPS driver wont install in W7

Pharos Igps-360 gps receiver only
September 28, 2010 at 03:17:21
Specs: Windows 7 & XP Sp3, Pentium r/32 Mb RAM
Trying to get my Streets & Trips (Pharos) GPS-360 receiver to work on my laptop was a frekin nightmare (due chiefly to MS's utterly useless new hardware
'wizard' and MS's so called online searches for software, even when it's their own * software).

On my W7, to install the driver for the GPS-360, users will find Windows utilities affording different names for the same device, ie; dev mgr lists it as 'other devices' and new hardware 'wizard' lists
it as 'device' and 'usb-serial controller', but neither simply tells the user that the device's "driver" failed to install (or if it did, I sure missed it).

Again, the new hardware 'wizard' simply (simple-mindedly) told me that the
'device' failed to correctly install and the device manager disclosed that there was no driver installed for "USB-Serial
Controller" (how that relates to users the least bit of helpfulness is beyond me as I have no "serial" port on the * machine, plus Googlng for the 'usb-serial controller' as well as 'GPS-360 not detected', and even 'the communications (COM) port is available, but no signal' all of which led me around in useless circles).

So I went to start>control panel> hardware and devices>Devices and Printers, then right-clicked the
'unspecified/other devices' icon, selected 'properties', then selected the "hardware" tab, then clicked properties and 'install/reinstall drivers', pointed it to the #5 disk's GPS Drivers>NT XP and presto the GPS-360 Receiver was detected and works with the pc and S&T.

The same lack of new hardware wiz and online search to install MS software is again experienced on XP's, so here's the low-low for XP users.

When the Xp's new hardware wiz prompted the new device was again a 'serial controller', I used the wiz's linkage to manually install the "driver", pointed it to the S&T #5 disk's 'GPS driver>NT XP' and presto, the driver installed.

Note the MS S&T 2006 install disks are number #4 & #5 (go figure why they're not #1 & #2, worse yet running #1 soon prompts to insert "run disk" and of course, MS doesn't label either disk as
"run disk", nevertheless how fairly obvious it is as to which disk needs inserted).

For those wishing to feel my pain read on (otherwise) hap-e-trials my friends...

Here's the low-low on the runaround that users are left to experiencing as a result of newhardware wiz and MS's online search and access to it's software...

My Windows 7 Pro's device mgr's explorer tree seems to be missing listings for "ports" and/or "1394 Host Bus
Controller" (assumedly W7P hasn't renamed these, like way too many other things).

Highly annoyingly, Googling the issue (for Windows 7) resulted in advice telling users to go to 'MS' (Hell) and update. I suspect that's crap and W7 isn't supposed to have 'ports' and '1394 Host Bus Controller' even listed in device mgr.

As such, my ms streets & trips gps receiver wasn't working and streets and trips says the receiver isn't detected (not that the driver isn't installed), but plugging in the receiver the first time, the 'new device' prompt did indicate the
"device" didn't successfully install.

As nothing really seemed wrong with my usb ports (as all of my external hard drives work just fine on any usb port), but when the GPS receiver was plugged into any one of my three usb ports, aside from the mentioned device's install failure, plus my device mgr ddin't list anything for "ports" or "1394-Serial Device", the device manager however listed "other devices" (which displayed an overlaid question mark icon) and associated with that it lists "USB-Serial Controller" (which displayed the overlaid error icon, yellow triangle with blk exclamation point).

The device mgr listed 'USB-Serial Controller' properties indicated no driver installed (code 28) and auto-search fails to detect a driver to install, plus when I tried manually searching for the driver in the Streets & Trips programs folder, nothing was detected in any of the folders (go figure).

Of note, the properties for USB-Serial Controller lists only hardware ids of... USB\VID_067B&PID_AAA0&REV_0300 and USB\VID_067B&PID_AAA0 and didsn't list a "vendor ID" entry (as I think maybe vendor ID is supposed usually be seen there).

Of added note, the properties for USB-Serial Controller lists the mfgr as unknown and the mentioned properties are the same when I plugged the receiver into each of my three usb ports, ie; with the exception of the properties indicate the receiver's plugged into
"Port_#0001.Hub_#0004" (I assume is my #1 port), "Port_#0002.Hub_#0004" (I assume is my #2 port) and
"Port_#0001.Hub_#0005" (I assume is my #3 port).

I'd also tried removing the GPS receiver's usb cable, shutting down, plugging it's usb cable and then booting up, but still streets & trips prompts "the communications (COM) port is available, but no signal is being received. Make sure the GPS receiver is turned on and connected to the port." Note the damned software's designer doesn't appear to have afforded so much as a thought for anyone who simply didn't yet have the driver installed for the GPS-360 (regardless that the * driver doesn't install when using the install disks).

Not certain why the action ctr's icon is no longer seen in sys tray, but I opened the action center (run>wscui.cpl), clicked
'troubleshooting', 'hardware and sound/configure a device, clicked
'advanced' (resulted in a ticked 'apply repairs automatically'), scan resulted in a 'hardware and devices' pane opening which afforded an 'apply this fix' link, clicked it, while it scanned, sys tray new hardware popup imparted that new device driver did not successfully install, also during scan, it prompted 'checking online' (which that aspect of the scan, it seemingly found nothing online as when the 'hardware and devices' pane re-appeared, it denoted "install a driver for this device - The driver for USB-Serial Controller is not installed. Install the latest driver for the device." And that pane afforded three options/links, ie; 'apply this fix', skip this fix -continue troubleshooting without applying this fix', and ''cancel'.

So I first tried 'apply this fix', but the
'resolving problems' pane, while imparting it was searching online for the driver, seemingly failed as the 'hardware and devices' pane's re-appearance merely stated 'troubleshooting has completed - troubleshooting was unable to automatically fix all the issues found. you can find more details below...
problems found - usb-serial controller doesn't have a driver - not fixed' and
"hardware changes might not have been detected - detected".

That pane afforded but action three options, ie; links for "explore additional options", "close the troubleshooter" and
"close". An optional "view detailed information" link was also afforded.

That link's use resulted in not much more than indications that the troubleshooter had ruled out a potential cause for not installing the driver, ie; windows update configured to never install drivers - issue not present.

I then tried troubleshooter once again, this time without selecting 'advanced - auto fix', and once more the sys tray new hardware popup prompted 'did not install'. As before, the hardware and devices pane resulted in listing three optional links, ie; "apply this fix", skip this fix - continued troubleshooting...' and
"cancel".

This time I chose 'skip'. It scanned again, reported again the same problem, afforded 'explore additional options', 'close troubleshooter', "close" and 'view detailed info'.

I chose 'explore' which simply closed the troubleshooter's hardware and devices pane and a new window was seen, ie;
"Additional Information" (eg; Control Panel\All Control Panel Items\Troubleshooting\Additional Information).

I chose that window's link for 'Windows Communties" which merely opened the IE browser to 'MS Answers' website (having it's search box already denoting
"hardware device", so 730,000 'answers' were listed in .3 seconds.

Note the 'MS Answers' website is at...

http://social.answers.microsoft.com...

..and true to MS's tremendious .3 seconds of effort, not so much as a customary search link was afforded (hopefully provding a refine search option) as likely that might've dearly cost MS another .1 seconds.

I finally found in S&T's troubleshooter's help, it says to get the (Pharos) GPS-360 to work on a pc, the user must first plug the receiver into the pc and only then install S&T.

Still no soap. Even installed S&T on my XP pc and still plugging in the GPS-360 resulted in new hardware wiz saying the device is a 'serial controller'.

I dare not say any more as it wouldn't be pretty.


See More: Streets & Trips GPS driver wont install in W7

Report •

#1
September 28, 2010 at 06:22:15
I stopped reading your post half way through. Pretty lengthy slam against MS.

That said, are you sure you are connecting the GPS to a USB port? If you are connecting to a USB port that is conencted to a motherboard header instead of being hard wired you may want to check to verify the header in use is not a 1394 fire wire header. They look the same.

From looking around a bit it appears that unit is quite old. The latest drivers I saw were for WinXP. I suspect the issue is the connection. If you have tried the device in a known working USB port then I am wrong. I am going by the messages you posted.

You might try installing it in a compatibility mode in Windows 7 if you know you are using a USB connection.


Report •
Related Solutions


Ask Question