Solved Roxio Creator Pro 2012 won't install

Toshiba / Satellite l305d
July 15, 2012 at 12:57:45
Specs: Windows 7 Home Premium 64-bit, 2.9GHz / 8000MB
Greetings! I just did a clean install of my computer to Windows 7 Home Premium 64-bit. No problem with loading software until Roxio Creator Pro 2012. It tries to install Direct X 9 runtime,
and then stalls. I've tried several times, but the installation stops at the same place. All the latest updates ARE installed, and I installed the Direct X End-User Runtimes download. Are there some components I'm missing? Any and all help will be greatly appreciated. Thanks in advance for your consideration and expertise.

See More: Roxio Creator Pro 2012 wont install

Report •

July 15, 2012 at 13:22:24
✔ Best Answer
Seems others have this issue. It turned out ot be some oddity of authentication.

I don't like the cure here but it gives you ideas.

Looks like when they created a new admin account it fixed some program.

I might be tempted to to a clean install, make all standard user accounts. Open each user account.. Do a complete shutdown and reboot to an admin user. Try the installation program then. Then do updates.

Google is evil

Report •

July 15, 2012 at 14:08:22
Thank You, jefro, for your QUICK reply. I used the 'cure' you suggested (by going to the forum location you supplied), and it worked perfectly. Many CUDOS for your solution!!! And, again, THANK YOU!

Report •
Related Solutions

Ask Question