Reinstalled Windows 7 not working properly

Mgi software Photosuite iii platinum edi...
June 4, 2010 at 01:01:43
Specs: Windows 7
Re-installed on my Windows7 (worked with my XP) and all the functions works perfectly, EXCEPT the scan-action. I get a message to check if USB setting is enable in BIOS. Where do I check/set this? Please help me! Regards, jenny.

See More: Reinstalled Windows 7 not working properly

Report •

#1
June 4, 2010 at 05:15:58
I'd suspect the drivers for your scanner rather than a BIOS
setting. Does your scanner appear in 'devices & printers' and
can you do a test scan? Also, have you checked on MGI's
website to see if there are any updates for Win7?

"I've always been mad, I know I've been mad, like the most of us..."


Report •

#2
June 4, 2010 at 07:12:30
sounds like the drivers for the scanner are incompatible. Download the drivers to your desktop.
Then right click on the driver and run as administrator. If that doesn't work, right click on it again and check for compatability. Run it in compatibility mode and you should be fine.

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

#3
November 1, 2010 at 03:16:06
thank you so much John, I only visit here again after a long time, and found your answer. I will try and download the driver now to see if that will work. Kind regards, jenny.

Report •

Related Solutions

#4
November 1, 2010 at 03:18:22
thank you so much for your advice, I will do that as you have suggested and I am sure it will work out then. kind regards, jenny.

Report •

Ask Question