Solved Must install NET framework v4.0.30319 but have v4.0.4...

December 5, 2016 at 18:56:06
Specs: Windows 7
Already have v4.0.40305.0 already why do I need a lower version any help. I cant get my DVD player to work. Ty in advance for any help

See More: Must install NET framework v4.0.30319 but have v4.0.4...

Report •

✔ Best Answer
December 6, 2016 at 15:12:32
Basically when a program needs Net.frameworks the author uses some version as the basis to make things work. In order to use that program you need the correct version.

If you have removed some program that used net.frameworks then you could remove that version. I see no real advantage to doing that.

Not all programs require net.frameworks to run. See the link below for further explanation.

https://msdn.microsoft.com/en-us/li...



#1
December 5, 2016 at 19:53:51
You need to try the other version.

Report •

#2
December 5, 2016 at 20:22:13
You don't need .net framework to get a DVD player to work. I'm guessing you're trying to install some software that requires it?

Can you elaborate on the problem you are having?


Report •

#3
December 5, 2016 at 20:25:24
I have been told that different programmes use different versions of Net Framework to work. I have 9 versions on m laptop and when I asked on a forum whether they could be removed that was the answer I got... "if you remove them something you have installed will stop working".

Another helper may have better information.


Report •

Related Solutions

#4
December 6, 2016 at 15:12:32
✔ Best Answer
Basically when a program needs Net.frameworks the author uses some version as the basis to make things work. In order to use that program you need the correct version.

If you have removed some program that used net.frameworks then you could remove that version. I see no real advantage to doing that.

Not all programs require net.frameworks to run. See the link below for further explanation.

https://msdn.microsoft.com/en-us/li...


Report •

Ask Question