Solved Multimedia Audo Controller

October 3, 2011 at 19:01:39
Specs: Windows 7
I have a Dell Dimension E510 and it had Windows XP on it and I installed Windows 7 Professional on it and now I don't have any sound and I have tried to add drivers to update the Multimedia Audo Controller but it is still not working I keep getting error message Code 28 and it says there is No Audio Output Device is installed. Please help!!!

ASTRA32 Summary below:
Sound Chip Vendor: Intel Corporation
Sound Chip: 82801g (ICH7 Family) High Definition Audio
AC'97/HDA Codec Name: Sigmatel STAC9221 A1
Sound Chip Vendor: Creative (was Ensoniq)
Sound Chip: ES1371, ES1373 AudioPCI

See More: Multimedia Audo Controller

Report •

#1
October 3, 2011 at 19:19:21
✔ Best Answer
Do you know if it is the 32 bit or 64 bit, On the dell support page for you model, it has the audio driver for vista 32bit which may well work for windows 7, but not if it is 64 bit

Here is the dell 32 bit for vista link....under audio...it's Sigmatel....looking for win 7 ...
http://support.dell.com/support/dow...

this one may work for 64 bit win 7

http://download.cnet.com/SigmaTel-H...


Report •

#2
October 3, 2011 at 20:04:38
You listed several different sound chips. You need to find EXACTLY which one you have, then install the correct driver. According to Dell, the sound chip is the Sigmatel STAC9220:

http://support.dell.com/support/edo...

Give this driver a shot. I realize it's for a Gateway & it's a Vista driver, but you have nothing to lose:

http://support.gateway.com/support/...


Report •

#3
October 5, 2011 at 17:29:57
I tried the Sigmatel driver and it worked; however,the sound is not coming thru. It is still giving me the error that the multimedia audio controller is not installed. Can someone let me know if they are able to find the other sound chip driver for Creative.

Report •

Related Solutions

#4
October 7, 2011 at 07:50:05
Can someone let me know if you are able to find the other sound chip driver for Creative.

Report •

Ask Question