microsoft (C) Register Server has stopped working

October 21, 2013 at 10:22:06
Specs: Windows 7
I have seen many other people with this issue and this is more of a solution for others than a question...

When trying to install/open some programs, this error would pop up, "microsoft (C) Register Server has stopped working."

Running as administrator would sometimes allow the program to install/open but with errors, hangs, and incomplete installs.

Here are some of the other "fixes":
1)sfc /scannow from the command prompt
"I did find problems with some files but this did not fix the problem, so good, but not the fix."

2)Modifying DEP (Data Execution Prevention)
"This is more of a workaround and doesn't completely fix the problem (or work at all)."

3)system restore
"This is due to being a time before you installed the problem program."

4)Memtest
"Will not do anything (unless there really are errors, but very unlikely)."

5)Renaming Windows folder in ProgramData.
"This will rebuild the folder but did not fix the problem."

6)Re-install Windows again!
"Yes, this fixes the issue, unless you use the same programs every time like most people do and install it on the fresh install."

The culprit and subsequent fix was AVAST! antivirus (the newest version as of this post). To fix the problem, disable AVAST! (and you might need to restart with it disabled)... until you are finished installing/running the program.

I absolutely love AVAST!, have used it for 7+ years and never had this issue in the past.

The reason most people see this happening is because antivirus is usually the first thing to go on after a fresh install... and even running the "Diagnostic startup" option in msconfig keeps AVAST! selected for startup. So, unless you actually disable it and stop it from running, this problem will persist.

I hope this works for everyone, and let me know if this works for you. I am not saying this is the end all fix, but instantly worked in my case. If you use AVAST! I would highly suggest giving this a try.

-Matthew

P.S. In my case, a lot of things would work fine but specifically Prismatik software (for adalight, ambx, lightpack) would cause this.

message edited by shadowmansm


See More: microsoft (C) Register Server has stopped working

Report •

#1
October 21, 2013 at 14:10:39
Thanks for the info. This would be a very good one for our "How To" data base if you feel that way inclined.

Always pop back and let us know the outcome - thanks


Report •
Related Solutions


Ask Question