Solved microsoft (C) Register Server has stopped working

June 27, 2012 at 04:55:19
Specs: Win7 Home Premium 64X
Hi there.

Out of nothing I get the following message whenever I try to open FireFox

"microsoft (C) Register Server has stopped working"

Internet Explorer won't open either, but it doesn't give a pop-up or anything, it just pretends I didn't open it.

The only way I can open a browser now is by running it as 'administrator'

I've taken the following steps, none of which have had any effect

- Booted in Safe mode, same problem
- Made a backup of regsvr32.exe just in case
- Reverted the so called faulty module 'MSVCR100.dll' to an older version
- tried the DEP on trick in windows system
- Fully updated win 7
- Fully scanned for viruses
- Re-installed Firefox
- reboot, reboot, reboot
- searched online for solutions

Getting kinda weird now

Exception code: 0xc0000417
Fault offset: 0x0008ae6e
Faulting process id: 0x1d4
Faulting application start time: 0x01cd530ed89da0e3
Faulting application path: C:\Windows\SysWOW64\regsvr32.exe
Faulting module path: C:\Program Files (x86)\Mozilla Firefox\MSVCR100.dll

See More: microsoft (C) Register Server has stopped working

Report •

✔ Best Answer
June 27, 2012 at 11:07:48
See if sfc /scannow from the command prompt finds any system files that were tampered with. Did you try using system restore to put your system files to a state before this issue started?

Andrew Leonard
BL Technical Services
IT Support Maryland

June 27, 2012 at 05:13:54
Run a RAM test on your computer. Any program can be reported as faulty when you have defective RAM. It's available on the Windows 7 install disc or on the repair my computer option from the F8 menu.

Andrew Leonard
BL Technical Services
IT Support Maryland

Report •

June 27, 2012 at 06:37:14
Let's see, that error is STATUS_INVALID_CRUNTIME_PARAMETER so something, somewhere, is passing an invalid argument to some C function. Sounds like a version mismatch in your system DLL's, and that'll be a pain to track down.

Shot in the dark: Did you attempt to install SP1, but have it fail on you part way?

How To Ask Questions The Smart Way

Report •

June 27, 2012 at 08:12:59

The Windows Memory Diagnostic tested the computer's memory and detected no errors

Report •

Related Solutions

June 27, 2012 at 08:14:50
All updates went well and haven't made any recent updates untill this problem started happening

Report •

June 27, 2012 at 11:07:48
✔ Best Answer
See if sfc /scannow from the command prompt finds any system files that were tampered with. Did you try using system restore to put your system files to a state before this issue started?

Andrew Leonard
BL Technical Services
IT Support Maryland

Report •

June 27, 2012 at 12:23:39
- Tried CMD: sfc /scannow, but it says Windows Resource Protection could not start the repair service (which is weird, because the service is turned on)

- restored from 27-06 to 21-06, this is 4 days before it started and that did the trick, now I just have to try and avoid it from happening again :D
I suspect it has to do with MS security essentials, which will get s---canned right away.

Thanks for the help guys

Report •

June 27, 2012 at 13:55:33
I suspect it has to do with MS security essentials
Strange, I haven't noticed anything. Your problem does sounded kinda viral, however, so great AV there, guys.

How To Ask Questions The Smart Way

Report •

July 9, 2012 at 11:59:14
I have the exact same system is behaving really strange for 3-4 days now...Chrome opens briefly, then closes, same thing for IE, and Firefox gives me the regsrv32.exe has stopped working error (but with Exception Offset: 0008af3e)
Application Name: regsvr32.exe
Application Version: 6.1.7600.16385
Application Timestamp: 4a5bca28
Fault Module Name: MSVCR100.dll
Fault Module Version:10.0.40219.325

The really wired thing is that if I click Firefox or Chrome like 20 times really quick it starts once and is working...If I close it and click it again it crashes again.

For Firefox I guess is has to do something with the automatic update. The regsvr32.exe is called with a temporary files in "C:\Users\MyUser\AppData\Local\Temp\" like 5ADC.tmp.

Also strange that System32 and SysWOW64 files are mixed...
FriendlyEventName=Stopped working
AppName=Microsoft(C) Register Server

I just want to mention that I also use MSE. Tried a full virus scan and installer Avira Anti-Vir for a second results.

Report •

July 11, 2012 at 16:15:47
I got this problem since yesterday. I can't open firefox or IE. Ive tried the DEP trick with the file regsvr32.exe but that doesnt solve it. Ive tried reinstalling firefox. Didnt help. Ive tried to run in administrator mode. Didnt help. Tried to replace regsvr32 from another windows 7 computer, but same window comes saying Microsoft register server has stopped working. Here's the event log details:

- System

- Provider

[ Name] Application Error

- EventID 1000

[ Qualifiers] 0

Level 2

Task 100

Keywords 0x80000000000000

- TimeCreated

[ SystemTime] 2012-07-11T20:27:21.000000000Z

EventRecordID 53856

Channel Application

Computer RossaEVGA-PC


- EventData


If I click to open firefox I get a small window 1 millisec before the actual error window and if Im really fast I can manage to open firefox in safemode. Thats what I did for this session. Im hoping for help or tips.

Report •

July 12, 2012 at 11:34:57
Update: I fixed my problem by scanning in safemode with Malwarebytes;

Files Detected: 4
C:\ProgramData\Windows\msseedir.dll (Trojan.FakeMS) -> Quarantined and deleted successfully.
C:\ProgramData\Windows\ccdxmmde.dat (Malware.Trace) -> Quarantined and deleted successfully.
C:\ProgramData\Windows\drss.dat (Malware.Trace) -> Quarantined and deleted successfully.
C:\ProgramData\Windows\xessmsxe.dat (Malware.Trace) -> Quarantined and deleted successfully.

This made Firefox work normally again.

Report •

July 22, 2012 at 14:50:22 are my f***ing hero! I tried all the tools in the world and traced the start of FF and IE with Sysinternals tools and had no clue what the heck was wrong with my regsrv32...

Tried full scan with Avira Antivir, Microsoft Security found. Tried reinstall of betas of FF and IE9, no success, just renamed this crappy ProgramData/Windows folder and everything works like a charm again.

Thank you so much...

Report •

August 2, 2012 at 04:37:16
I found the same files in C:\ProgramData\Windows on my x64 Windows box.
After renaming the directory, all worked ok again. Thanks !

Report •

August 17, 2012 at 12:36:47
I get an error message at every start-up.
Error Message:
Microsoft(c) Register Service has stopped working. (regsvr32.exe)
Can anyone tell me what to do please ?

Report •

August 21, 2012 at 07:15:01
Start a new thread. Can someone lock this?

Andrew Leonard
BL Technical Services
Emergency IT Support

Report •

Ask Question