Solved Messed up Windows 7 PC can't play any games

August 2, 2015 at 07:33:14
Specs: Windows 7, 3 GB
I've just installed AVG PC Tune-Up because my PC was lagging like crazy. It removed the lag but it has also returned my computer to some kind of "previous version". Some of my files are gone, some programs too. And all of this happened after another issue. It asked me to reboot.I did. I couldn't log in to my Windows profile. So I started in Safe Mode and edited my registry as Microsoft Support indicates. After that, I rebooted and I got something completely different from what I had before. And besides all that, I can't play games. When I try to login in to any multiplayer game I get no response from the server.I have no restore points, unfotunately. I really need some help, please.

See More: Messed up Windows 7 PC cant play any games

Report •

#1
August 2, 2015 at 08:53:00
✔ Best Answer
Wow, sounds like you have lots going on. Things that I think of immediately. Did you back up the registry as I am sure that windows suggested. If you you should be able to restore it.

What did windows suggest you edit in the registry otherwise, thus is usually only a last ditch expert used by someone extremely familiar with the registry. There is a chance the avg program changed port settings that might be specific to the game you are playing.

Are you able to go online at all? If not what game do you wish to play that way we can check to see what settings need to be changed.

::mike


Report •

#2
August 2, 2015 at 11:58:37
Here are some details:
https://support.microsoft.com/en-us... I used Method 1 from this link.
I am actually able to go online. What I tried to play was League of Legends and it said I am not getting a response from the server when I log in. There was also this silly game on facebook. Not much, but it was the exact same problem(couldn't contact the server) and I thought that raised some questions.

On the other hand, I tried connecting to battle.net and Steam and it was all good.
But, when it comes to LoL, I tried all they had in the support section. Also, I tried disabling IP helper, and changing my DNS to the one they recommended.
Furthermore, I did find one specific aspect really strange. On my desktop, I got back shortcuts (which I had deleted a long time ago) from games/programs not installed anymore on my PC and also gadgets(same situation).
Thank you for your answer, I hope you can find something for me.
**Update: I backed up my registry and now my theme is no longer Windows 7, but actually looks more like 97.Unchangeable. I updated to Service Pack 1, no change. And now, games work. Skype doesn't. Those old shortcuts and gadgets are gone too. And I guess all I want now is Skype because I am so done.Honestly.

message edited by eugen_cutic


Report •

#3
August 2, 2015 at 16:21:21
Couple of tips for the future:

1. Gadgets are no longer supported by MS (seen as a security risk).

2. Generally lay off magic computer fixer programs as they often do more harm than good.

Can you give us a screen shot to show what it now looks like - we've no idea and it might be something we will recognise? Put it on here and give us the URL it then provides:
http://www.zippyshare.com/

Always pop back and let us know the outcome - thanks


Report •

Related Solutions

#4
August 2, 2015 at 22:01:07
There should be a 'rescue center' option in AVG tuneup where you can undo the mess it's caused. I'm not sure if all the other stuff you've tried will affect its ability to recover but give that a try.

Report •

#5
August 3, 2015 at 06:22:23
It's done. So after all of that, I turned of UAC and everything magically came back to normal. I don't know how and why but it is all fine

Report •

#6
August 3, 2015 at 07:50:42
Good to hear and thanks for the feedback. Did you then turn UAC back on again?

Always pop back and let us know the outcome - thanks


Report •

Ask Question