keyboard/mouse/sound control wierd behavior

Dell Vostro 1520 laptop computer (intel...
June 4, 2011 at 13:52:00
Specs: Windows 7, Intel core2 DUO T66700
Hi,
I have a dell 1520 vostro laptop. Since 1 week keyboard is behaving strangely:
1.When I reboot and bring up the machine, there are 2 user accounts, I am unable to click with my mouse on one of the accounts, after repeated reboots sometimes it ends up highlighting one of the accounts then I press ENTER on key board and login (mouse click on user account never works). After I login if I click the left mouse button it works. (which proves that mouse is not dead)
2.Once I login and open firefox browser, I go to address bar, and type goog, it doesn't display the previous webpages that have "goog" in their name. I see continuous flickering but no display
3.For many of the web forms that have a drop down, If I try to pick one of the many choices, when I click on the drop down, it doesn't expand and show the drop down, it again opens and immediately closes, I see same flickering behavior. I am selecting the drop down and then using alphabets, arrow keys on keyboard to navigate and pick the right choice.
4.If I am in a browser window and try to switch to my notepad document using ALT+TAB, it forces the browser to go to previous page.
5.At top right bottom on the task panel, there is a sound button for volume control. When I try changing the sound level to low, it automatically goes up....
During boot up, I pressed F12 and ran an express memory, hardware test and specific tests for keyboard, mouse and sound and don't see any failed tests, everything passes. I am completely lost as to what could be happening.
I checked my keyboard layout its set to US style layout.
I tried to uninstall the driver for keyboard (ps/2 keyboard driver) and reinstall. It said it was not able to reinstall as it couldn't find the driver but for some strange reason after reboot I am able to still use keyboard...
I searched web and see above options suggested but none seem to work so am now completely clueless. Any help will be greatly appreciated.
P.S.: I don't remember having any liquid spills on machine, and given hardware tests passed am ruling out any such problem..
Thanks

See More: keyboard/mouse/sound control wierd behavior

Report •

#1
June 4, 2011 at 16:53:46
Two things come to mind, one is updating your drivers (especially if this is an upgrade to W7) and the other is scanning for an infection.
First download and install Malwarebytes and run that to find any infections your antivirus program may have missed.
Second go to Dell's website and download the latest drivers your your system and your version of Windows 7 (32bit or 64bit) and install them.

Let us know the results.

You have to be a little bit crazy to keep you from going insane.


Report •
Related Solutions


Ask Question