Invalid Partition Table...

February 10, 2010 at 11:44:58
Specs: Linux i686
Ok, guys I really messed up. Here is what happened:

I had an external harddrive I was borrowing to backup my files from XP, to upgrade to Windows 7. Everything went fine, and I installed windows 7 great and unbacked up all my files from the external harddrive.

Now, the guy I was borrowing it from said how his computer broke, so if I could install ubuntu 9.10 on the external harddrive and bring it to him. So I did, and everything went fine, and I took it over to him.

NOW when I came BACK, THIS is where the problems start. I load up my computer thinking it would load grub and load windows 7, but NO, grub says how the selected drive is not find or something. I supposed it was looking for the external harddrive, when it's not there. So I loaded ubuntu live CD, which I am on now, to search on how to remove grub. This is where I made my mistake. I searched "how to remove grub" instead of "how to remove grub windows 7" it brought me to a topic saying to load the windows XP recovery console disk and do fixmbr or fixboot. I should have known this was for XP, not W7, but i figured it would work with W7, too. I did what it said and i did fixmbr at the recovery console, a message said how the partition isn't recognized or something and if i continued it might damage the partition. I was wondering whether i should do it or not, so i decided not to, and try fixboot instead, so i did.

fixboot didnt say any error, so i thought it was good to go. when i exited and restarted, though it said "NTLDR is missing"! damn.

So i loaded windows 7 DVD this time, and i went to start-up repair. it took like 3 hours. when it was done it said how it had to repair a partition table. When it restart it said "NTLDR is m:D" seriously, it had a smiley face, there! but it was not a ":" and a "D", it a right side up smiley face with a box around it. but it was the same size as a regular character.

Anyway, i looked online again and this time i did "how to remove grub windows 7" like i should have to begin with and i wouldnt have this problem. It said to do "bootsect /nt60 C:" and "/bootrec fixmbr", if "bootsect /nt60 C:" didnt work.

I went to command line in windows 7 disc and typed "bootsect /nt60 C:" restarted. NOW it said "bootmgr is missing...".

So i tried "/bootrec fixmbr" and NOW it says "invalid partition table".

Now what? lol. im thinking just to borrow that external harddrive again and backup all my data with testdisk... but that will take some time, is there anything simpler? or even something that doesnt require me to go get that ext. hdd? thanks a million!


See More: Invalid Partition Table...

Report •

#1
February 10, 2010 at 13:26:50
Try bootsect /nt60 c: /mbr & post back.

Windows 7 News!


Report •

#2
February 10, 2010 at 14:15:26
Hi. Thanks alot for your reply! I did what you said and it said:

C:<\\?\Volume{c5fc6546-16d2-11df-9ee5-806e6f6e6963}>
Could not open the volume root directory:
The parameter is incorrect.

\??\PhysicalDrive0
Successfully updated disk bootcode.

Bootcode was successfully updated on at least one volume.


Report •

#3
February 10, 2010 at 14:15:51
Oh, and I restarted and it still says "Invalid partition Table."

EDIT: Whoops, sorry for double posting.

EDIT2: I read that I can repair my partition by using linux's TestDisk function. How do I get to this function, and use it, if it is in ubuntu? Thanks alot!


Report •

Related Solutions

#4
February 10, 2010 at 16:39:28
Is your Windows partition currently set active? If not, you need to ensure that it is active in order to boot from it.

Windows 7 News!


Report •

#5
February 10, 2010 at 17:59:14
I seriously doubt that is the problem, as it was booting from it before, and the error states that the partition table is invalid. When I go into Windows 7 DVD, it doesnt detect the Windows 7 operating system, either. It says it is RAW.

Report •

#6
February 10, 2010 at 20:04:51
In that case, download & run Testdisk from a Live CD. Simply boot from the CD & select from the available command what utility you wish to run.

Windows 7 News!


Report •

#7
February 10, 2010 at 20:53:36
Sabertooth is right! I had actually started running testdisk before you posted that message. First, it didn't work because when it said if I wanted to search for a Vista partition, I put N because it's a Windows 7 partition, but it seems I still needed to put Y, because maybe Windows 7 is similar to Vista. Once I did that I did a quick search, but then I had to do a deeper search, and then I found it. I did "Write" and rebooted. It said bootmgr was missing, so I put in the W7 DVD and it found an error. I restarted. Said the same thing. Went back into the W7 DVD and this time it finds the Windows 7 installation! yay! so i hit next and went to startup repair, and it repaired it. i restarted and it worked perfectly! im now on my original windows 7 :D im so happy! thanks for helping saber!!! (i wrote this post to help those who have the same problem. JUST USE TESTDISK! It saved the day, yet again! (as it has with many others) It's a miracle program!)

thanks


Report •

#8
February 10, 2010 at 21:42:21
Good deal!

Windows 7 News!


Report •

Ask Question