intermittent cd function of dvd/cd-rw IDE config

July 15, 2012 at 09:59:08
Specs: Windows Vista, 4 GB
First, if this is a repeat post forgive. When i registered a flash msg said my question "will be stored - but i can not find it anywhere!"
Toshiba Satellite L305D-S5897, RAM: 4 GB, Processor: AMD 2GHz, BIOS: InSydeH2O 1.40, Mats---a (Panasonic) DVD/CD-ROM(RAM): UJ-850S ATA.
This device has worked flawlessly and then not seemingly w/out rhyme or reason. All the usual fixes have worked in the past - cdgone, filter delete, reg fixes, BIOS upgrade and most recently restore to out-of-box condition.
80 hours of research leads me to believe this has to do with IDE configuration (and an inability to make changes in BIOS).
This discussion thread is closed.
http://webcache.googleusercontent.c...
i hope that "jam" & "Othehill" will take a look at this with me, please. How do i upload a photo of current configuration

See More: intermittent cd function of dvd/cd-rw IDE config

Report •

#1
July 15, 2012 at 10:43:25
There is only one post attributed to you. Clicking on any user name will bring up some history.

jam is no longer active on this board.

Posting a screen shot is premature at this time.

Do your optical drives show in My Computer or Device Manager?

Can you boot from a bootable CD or DVD?

Have you installed/unistalled any scanners or burning programs?


Report •

#2
July 16, 2012 at 07:27:49
Thank you for the response, answer on # of posts shown and jam's status.
i think you will need a screen shot of DM and details.
Yes, optical drive shows in both places alternately as EITHER a DVD OR CD drive.
Yes, i can access .exe programs from DVD - but not CD. There is significant hang time in Explorer window (30 - 45 sec), then prompt to format disk. Cancelling that prompt then shows DVD label in My Computer, and right-click dialogue is visible.
The laptop has been restored to "Out-of-box" condition, so no scanners or burning programs have been modified since.
Since restore, i was able one time to get a CD to read, but only a store-bought music CD, not a bootable CD, and then not able to recognize any CD again.

Report •

#3
July 16, 2012 at 08:53:58
I believe that your drive is failing. Combination optical drives use TWO different lasers to read/write because the wave lengths are different.

It appears CD laser is failing.

If the unit reads sometimes the likely cause is laser failure. Writing a disk takes more laser power than reading one so the first thing to fail would be the ability to write disks of on type or the other. Store bought disks are better quality than self burned, so it is understandable store bought may work but not disk you burned.

I suggest you search for a compatible replacement drive

One thing I failed to mention is that you should attempt accessing the disks through Windows Explorer. Autorun is not a good indicator of drive condition.


Report •

Related Solutions

#4
July 16, 2012 at 17:18:39
Thank you again. i appreciate your knowledge level. However, jumping to the conclusion the drive is failing based on intermittent failure to be recognized as a DVD OR CD drive seems premature.
Please, i tried to be as thorough and clear as possible in my description. There are times the drive is listed as a CD drive OR a DVD drive.
Again, i point out reading music CD's, but not reading a bootable CD does not spell failure to me.
I DO use Explorer to access the CD in drive (please see above about Explorer window hanging). Could you please address my question regarding IDE configuration/how to upload a jpg screenshot before you tell me to go out back and put it down?
This time, as with others it worked fine in one instance, and in the next use (10 minutes later) not, then fine again. i am asking for your help with determining what the correct configuration of the drive as listed in the IDE config OUGHT to be.
Thanks again.

Report •

#5
July 17, 2012 at 08:52:37
If the BIOS settings were the issue then the drives would not work at all.

You haven't stated if you use auto play or not. As I stated above that is not a reliable method.

I will attempt to explain HOW the drives function. The way you can write MORE data to a 5.25" disk is to burn smaller pits into the media. Smaller pits require a laser with a shorter wave length.

Now, the SAME laser is used to Write and to Read. The way that is done is to vary the Intensity of the laser beam. When the laser is wearing out it may still read some disks but not be able to burn.

I should have mentioned that the lens covering the laser can also cause problems due to soot building up on the surface from the burning process. You can clean that off with a lens cleaning kit.

Going back to the issue of playing some, but not all disks can be attributed to the auto play settings, or the quality of the disk being read. Disks burned on your machine are generally not going to be of the same quality as professional disks.

The fact that sometimes your drive is identified one way or the other may indicate the firmware could be updated. Again, this is not a BIOS setting.

Post the exact label you read in Device Manager for your optical drive.

Your drive is listed as an ATA device.

As such, it should be able to run in a DMA mode. Check in the drive listing in Device Manager to see how it is running. If you find it is running in a PIO mode then you may need to install the correct chipset drivers for your laptop.

Being that this is a laptop, you don't have the BIOS setting flexibility that you would have with a desktop. So the default settings should produce the desired results.


Report •

#6
July 17, 2012 at 21:18:09
i am using Windows Explorer to open the dialogue window. Please see my description above.
the EXACT listing in device manager is above. As i said, it alternates in drive ID sometimes it lists as a DVD, others as CD -rom/ram.
Yes, it can be a BIOS issue as toshiba/InSydeh2o has some peculiarities as well as this particular mats---a does not have a firmware update as panasonic is no longer providing support for this model among others. i have gotten to this point in the analysis and need some help. i pick you because of the link i posted in my first post and the IDE issues listed there. i am frustrated that you will not address the question i am asking. which is, 1) how can i post a screen shot of the odd descriptions in device manager relative to IDE and controller, and 2) can/will you help me sort that out.
again, i have done every other step - cleaning, checking contacts up to and including restoring to out of box condition. will you answer the two questions i have asked? i appreciate you and will understand if you don't want to - just let me know and i will move on. thanks.

Report •

#7
July 18, 2012 at 08:01:16
See the links below for help with that.

I just use a digital camera.

You then need to upload the file to a hosting service like imageshack. Use the link below.

http://imageshack.us/


Report •

#8
July 20, 2012 at 09:44:51
Thank you very much. i am grateful.
http://imageshack.us/g/845/mycomput...

Report •

#9
July 20, 2012 at 14:45:13
I don't see anything wrong with the BIOS settings. The drive is identified by model there.

Your second and fourth images are too small to read. Expand the box to full screen and shoot it again.

Your first image lists the drive as an audio CD.

That would indicate to me that you have the Vista settings configured to treat any disks as audio disks. That is the weakness in Windows.

Go to Control panel> autoplay and try inticking the box for autoplay. Or try changing the settings to mixed use.


Report •

#10
July 21, 2012 at 08:17:41
Thank you again. i have reloaded images 2 & 4 with bigger size attributes.
They show screen shots of drive details and discrepancies in drive identification dvd-rw OR cd-rw. i can not determine the origin of the changing identification and how to default or force a recognition of the drive as BOTH - dvd/cd-rw???
i have (again) fiddled with autoplay. As you suggested - it is off on all individual categories and off in the settings dialogue. it does not seem to matter one way or the other. i can read executable files on dvd, video file dvd, but ONLY music files on cd homemade or otherwise.
Research indicates the recognized location of the drive on the partition has something to do with this. Thank you again.

Report •

#11
July 21, 2012 at 08:31:28
I think you are fixated with the CD/DVD designation. In all the screens you linked the optical drive is identified as a Mats---a UJ-850S ATA device. There is nothing wrong in the BIOS.

If anything is wrong at all it is in Windows. I think it is simply your autoplay settings. However, you stated you have messed around with the filters. While MS may instruct you to remove those filters sometimes, they are there for a reason.

From all your responses above I still stand by my evaluation. Either the autoplay is not allowing access for certain disk types or the drive or lens is the problem. The fact the drive takes 30/45 seconds to access a disk indicates it can't read the disk. The disk could be defective, the laser is not functioning as designed or the lens is dirty.

If you are reluctant to replace the drive then perform a repair install of WinXP to restore the filters. If you still have issues then replace the drive.

edit

Rereading your first post indicates you performed a factory restore. That leaves the autoplay settings or a defective drive.

You do know that WinXP can't natively BURN DVD media?


Report •

#12
July 23, 2012 at 17:36:01
WinXP????
i'm running vista (???)
and auto-play is OFF. has been and all Autoplay settings are "Do Nothing"
Thanks for your help. i am having trouble communicating what the symptoms are and what i have determined thus far.
Thanks for your assessment of the BIOS (if by that you mean the IDE settings?). again - the BIOS has no options to change drive location on a laptop and is set to defaults....
Have a good one. thanks again for taking the time
!

Report •

#13
July 23, 2012 at 18:40:14
Sorry about the XP comment. This thread has been going on for a while and I had a lapse there.

Report •

#14
July 25, 2012 at 13:15:07
no problem ;) i really appreciate your thoughts. But i really need to verify the IDE settings. so i posted more specifically for that specific issue in different forum/thread. ironically enough, the response skipped over my question and started talking about filters and MS hotfixes... sigh. patience is queen ;)
take care

Report •

Ask Question