Installing Printer, cannot locate drivers

Hewlett-packard / Deskjet 5940
July 26, 2012 at 11:31:12
Specs: Windows 7 Professional 32bit , Pentium E5800/2GB
I needed to install my HP deskjet 5940on my computer. Windows did not install the device, as it would with most usb devices. I then tried to manually add a printer and the driver was not listed. I searched online and I could not locate a driver for the printer. The closest thing that I could find was a 2K/XP installer that would not run on 7. The printer is compatible with Win 7, made more so by the fact I am running the 32 bit version.
The drivers do exist for Windows 7. I have another WIN 7 PC where the printer works and the computer has the driver. I have the original software disk but it only works with 2K and XP and older, like mentioned above. So my question is, is there a way to retrieve this driver from the disk or from my other computer where the printer works, or is it actually possible to locate a working driver online.
Thanks in advance for the help

See More: Installing Printer, cannot locate drivers

Report •

#1
July 26, 2012 at 12:09:35
http://h20000.www2.hp.com/bizsuppor...

Googling is quicker than waiting for an answer....


Report •

#2
July 26, 2012 at 12:12:48
I think it may help you http://tinyurl.com/cfk285j give your feedback !!

Solving Technical queries is my passion and I just Love it !!


Report •

#3
August 13, 2012 at 11:20:45
My orriginal message was a little incorrect. I also found the drivers that both of you sent me links for, sorry .....
So, for kicks i tried the drivers you supplied links for again. Still no joy, uninstalled drivers in device manager and disconected the printer then let windows deal with it once it was reconnected, Windows found something and sucessfully downloaded and started to install it, then it failed. Then i tried the HP site driver again and same failure.
Now the printer can be seen in the printers and devices section as being fine with no Windows view errors, but once the printer is tried to be used it does not work. The HP wizard still says that drivers are not installed correctly and directs me to uninstall the drivers, but this creates a loop that does not work ....
So I am stuck. Also, sorry for the lenght of time it took me to reply.

Report •
Related Solutions


Ask Question