IE9 not recognizing that Silverlight is installed

Hewlett-packard /
August 15, 2012 at 05:12:47
Specs: Windows 7, Intel i-5 / 2.40Ghz
I watched Skyplayer on IE9 and everything was fine. I tried it on Google Chrome where it was also fine. However I have issues with Chrome (mouse doesn't work properly) so uninstalled it. I now find that when trying to use Skyplayer it comes up with a message saying I need to install/update Silverlight - even though my add-on list says it is enabled and the Control Panel lists it.
I'm running latest version of Silverlight on Windows 7 on a HP dv6 lPTOP

See More: IE9 not recognizing that Silverlight is installed

Report •

#1
August 15, 2012 at 09:11:05
Uninstall silverlight and reload it maybe.

Google is evil


Report •

#2
August 15, 2012 at 14:04:34
jefro, I've uninstalled and re-installed everything under the sun! That includes Google, Google Setup, Google Toolbar, Adobe Flash (for some reason) but, nope, nothing works.

And yes, I think Google is evil too.


Report •

#3
August 17, 2012 at 08:40:27
Might look at event logs for any more ideas.

Guess you could try restore point to a time when it worked.

Might end up reloading the entire OS from OEM media. It has never failed me yet.

Google is evil


Report •

Related Solutions

#4
August 17, 2012 at 10:20:29
Jefro, thanks, but I can't remember when it started so a restore point could be difficult. Is there a way to discover when I started using Chrome? Don't really want to go back to OEM reload. Many thanks for your interest and support.

Pete McS


Report •

Ask Question