I keep getting error 1603 (msi.chm)

Asus Bdr 8x usb 2.0 cyberlink-powerdvd b...
January 30, 2011 at 09:11:18
Specs: Windows 7, i7 CPU/ 4 Gigs Ram
I am trying to install Cyberpower BD Solutions onto 64 bit vers. of Windows 7 Home premium. I keep getting a 1603 installation error. The reason is because my blu-ray software stopped playing blu-ray discs. The computer tells em to consult windows help, but they (not surprisingly) don't have an answer. I am installing from a disc that came with a Light On multi-format blu-ray drive that I've had for 2 years now.

See More: I keep getting error 1603 (msi.chm)

Report •

#1
January 30, 2011 at 09:35:59
If the computer and drive worked when you bought it then I might consider one of a few ways.

One may be to simply test it with a live linux cd and see if the drive works. That may take a bit of advanced linux skills however.

Second may be to consider a "recovery point" to a time when it worked. It may be that you can roll back in time to a set point. Open help and support for help.

Last may be a fully restore to OEM state. Your owners manual would tell how to return it via meda that you got or had to create or a special hot key at boot.

"The era of big government is over," said Clinton 1996


Report •

#2
January 30, 2011 at 10:21:14
I have no OEM disc. My computer is a custom build. and I upgraded from xp to win 7, which means no factory restore. I was never asked to make any kind of key or anything. I just did a fresh re-install of Windows 7 at the end of Nov. early Dec. Blu rays worked just fine until this month just yesterday. DVDs seem to play just fine...its only blu-rays that are not working.

Report •
Related Solutions


Ask Question