How to activate serial ports in DOS safe mode

September 22, 2010 at 08:53:51
Specs: Windows 7
I have an old DOS program I need to use for work which uses COM 1 for file transfer. In Windows 7 the app locks up after a few minutes, in fact locks the entire PC. I sispect it's a windows issue for the com port. I tried to boot to DOS in safe mode but the com port is not activated. How can I activate com 1 serial port within DOS?

See More: How to activate serial ports in DOS safe mode

Report •

#1
September 22, 2010 at 09:12:38
There is no DOS in NT and later Windows.

You may need to boot in DOS to run that app.

Which means you'll need a FAT prtition. Or run it from floppy.


=====================================
Helping others achieve escape felicity

M2


Report •

#2
September 22, 2010 at 10:10:42
NT 32bit Windows Operating Systems do not allow direct port access in the NTVDM:

http://en.wikipedia.org/wiki/Virtua...

You need a standalone **-DOS environment as stated above, which you do not have, and please do not call it DOS SAFE MODE because it ain't!! IT IS NT COMMAND PROMPT

If you are running Windows 7 64bit it does not have NTVDM what-so-ever....


Report •

#3
September 22, 2010 at 11:25:22
It amazes me how so many businesses will upgrade their computer hardware but not the programs that run on them.

Are you sure you must use that program? If so you may be able to use it in a virtual PC environment. Or just get an older computer, install dos on it and run the program there.

Dos configures the com ports exactly as they are specified in cmos/bios setup. If the bios show COM 1 is at 3F8H with IRQ 4 then that's how dos will see it.

Real men don't use AntiVirus; they just reformat


Report •

Related Solutions

#4
September 22, 2010 at 11:41:45
Hi DAVE,

Correct, but DOS or the DOS app may need to set speed, etc with MODE.

Most decent apps will set up the ports. LapLink springs to mind.


=====================================
Helping others achieve escape felicity

M2


Report •

#5
September 22, 2010 at 11:54:54
Oh yeah, I forgot about that. It's been about 15 years since I set up a 14.4 modem on my 486!.

Real men don't use AntiVirus; they just reformat


Report •

#6
September 24, 2010 at 13:09:56
Consider dosbox.

Why did it take me over a year to phone in a problem to ATT?


Report •

Ask Question