How should I fix Win7 can't find taskmgr.exe?

October 25, 2010 at 16:20:39
Specs: Windows 7 Pro 64bit, AMD64 X2 2.6Ghz, 3Gb DDR2 800Mhz
Hey folks, second thread in the space of 2 weeks from me, this is pretty unusual, but it's unusual circumstances I find myself in!

Windows 7 Pro 64bit, I right clicked the Task Manager system tray icon like many times in the past, and somehow when I clicked the Close option, it went into an insane loop.

It broke. Y'know how when you set it to maximum refresh rate it moves along steadily? Well, it was moving at 100fps, and the CPU Usage was rocketing and plummeting like 010101010 activity. The Task Manager window had failed and stopped responding, so I couldn't hit the cross. I couldn't end the process because the tool (Yep, the utility itself) to do it was screwed up.

Fortunately I had Process Explorer tucked away, so I launched that without any issues and Ended the Task Manager process from there, and that closed it off successfuly.

It didn't solve the problem though, now when I try to open Task Manager I get this message:
"Windows cannot find 'C:\Windows\system32\taskmgr.exe'. Make sure you typed the name correctly, and then try again."

I have browsed to that folder and the Executable is still there, under the correct file path. If I double click the executable itself, I still get the same error. It's like the error displayed is a lie.

And that's my awesome, but true story, and if anyone has any bright idea's beyond Repair Installing/Formatting over this ridiculous problem that not even years of XP usage managed to pull off, it would be greatly appreciated!

Edit: My apologies to the Moderator who was forced to modify my Question as I didn't phrase the issue as a question in the first place -_- Thank you for ammending it :)


See More: How should I fix Win7 cant find taskmgr.exe?

Report •

#1
October 25, 2010 at 16:32:04
You may find something in the following link
http://www.techspot.com/vb/topic146...
I glanced through it and some people had some interesting answers...good luck

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

#2
October 25, 2010 at 16:46:07
Two Thumbs up man! I think I actually brought the latter most problem on myself. I already had that utility, and sorta remember hitting up that option -_- (Sorry, for clarity, one of the posts in the thread refers to using the Sysinternals Suite. It contains Processor Explorer, a tool I already had independantly acquired and inadvetently used in a manner which borked TaskMgr).

Whatever I told Processor Explorer to do, it caused that problem. The insane looping of TaskMgr though, what a freak error, but thank god it didn't result in anything corrupted.

Thanks so much! Problem already resolved, and not even an hours passed :D XpUser4Real, pat yourself on the back! :)


Report •

#3
October 25, 2010 at 16:48:35
Thanks a million for posting back! I hope this will help others with the same problem
;-)
Glad I could help.

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •
Related Solutions


Ask Question