Solved how can I message Jeff Root?

November 24, 2017 at 21:21:49
Specs: Windows 7\
I may have located the 'Foxit-Reader-trying-to-connect-to-the-internet' issue. Using Systernals Process Explorer, we can view the threads of a running program. I use Peerblock to filter I.P. traffic. When I run Foxit Reader it tries to connect to 52.73.172.8 two times per second via the thread: "ntdll.dll!TpCallbackIndependent+0x236". looking at the stack on line eleven I see:
"ConnectPDFService.dll!FLS_PlugInMain+0x51d"
I suspend the thread with no consequences to the useability of the app.
Maybe the request for internet connection is for a call to (sync with?) the Apps browser plug-in? Do the older versions have the option to install a Foxit plugin during installation? If not maybe those versions predate the plugin... More expertise than mine is needed to follow this trail to greater clarity. Hope this helps. ~A fellow offline worker :)

See More: how can I message Jeff Root?

Reply ↓  Report •

#1
November 24, 2017 at 23:41:21
"how can I message Jeff Root?"

You can't if you have no contact details for him.


Reply ↓  Report •

#2
November 25, 2017 at 06:13:20
✔ Best Answer
Go back to the thread you're referring to, click on his name & send him a private message.

Reply ↓  Report •

#3
November 25, 2017 at 08:00:50
Thank you both for your responses. I choose that title before I knew I had to register to make a post. I was not wanting to register but decided to so that he could see this.. Now that I have registered I have sent him a private message.

Reply ↓  Report •

Related Solutions

#4
November 25, 2017 at 19:25:24
Thank you!

I am not currently running Windows 7. My Windows 10 computer
is not connected to the Internet, and if I recall correctly, by default
Windows 10 displays PDF files with Edge, and I haven't changed
that -- I haven't installed Foxit. But this info could still be helpful.

-- Jeff, in Minneapolis


Reply ↓  Report •

#5
November 25, 2017 at 20:09:10
I'm not Jeff Root, but I do notice you don't have symbols configured.

Also, Foxit isn't using network ports to communicate to something else on your PC. You can tell because the IP address it's trying to contact isn't yours. I did a reverse IP lookup, and got cws.connectedpdf.com. There's no info on the owner of connectedpdf.com, but the was registered by a Chinese company, HiChina Zhicheng Technology Ltd, specifically. Could be some sort of cloud service option that Foxit's trying to access.

Finally, I use SumatraPDF, for what that's worth. It's an open source PDF reader. Except when I'm on Win10. Then I use Edge, which is the best touch-based PDF reader I've seen for Windows.

How To Ask Questions The Smart Way


Reply ↓  Report •

Ask Question