hilariously slow transfer rates pc-USB

July 5, 2012 at 00:13:50
Specs: Windows 7 64bit, i7-2600k, (3.8Ghz)/ 8Gb 2133
recently tried to transfer a 1.5Gb video file from win 7 ultimate (64) to a thumb drive, and it has taken 45 min to do so, now i am pretty sure usb 2.0 should be able to handle that faster, the usb controller is for the front panel of the tower, and nothing else is connected through the front, just trying to figure out what the bottleneck here is, the drive that has the files is almost empty and ram is well in excess of what is needed, any thoughts?

the drives being used are
WD 1TB green - hp 8GB thumb drive


See More: hilariously slow transfer rates pc-USB

Report •

#1
July 5, 2012 at 04:17:08
The USB 2.0 standard encompasses three data transfer rates:

Low Speed: 1.5 megabits per second, used mostly for keyboards and mice.
Full Speed: 12 megabits per second, the USB 1.1 standard rate.
Hi Speed: 480 megabits per second, the USB 2.0 standard rate.

Not all USB 2.0 devices support Hi Speed transfer, so your pen-drive might be only Low Speed or Full Speed, but you really should verify this by looking at your pen-drive's specifications online where it's writing speed is given.

I can't verify that for you since you've only said it's an HP one. It's full model name is required to find out it's performance specs.

You can have a dozen pen-drives of different makes, all USB 2.0, it doesn't necessarily mean they all write at the same speed.


Report •

#2
July 5, 2012 at 04:44:10
It does sound slow:
"Specified speed of USB 2.0 is 480 mbps (in other words, around 60 Million Bytes per second, or 57.2 MB/s), but 57.2 MB/s is NOT the actual data rate."
as per:
http://lyberty.com/tech/terms/usb.html
1.5GB= 1500MB divided by 57.2MB/s= 26.22 seconds theoretical
But probably two to four times that in practice depending on the device.
Using the similar approximation for USB1.1:
1500MB divided by 1.4MB/s = 1070 seconds = 17 minutes theoretical (17 x 2.6 = 45 minutes)
or much closer to what you are seeing.
(the math is making quite a few assumptions and approximations to just get to a point)
It looks like either your flash drive or your front USB port are operating at USB 1.1
To test this you will need to try the flash drive on a rear USB port on this computer and on another computer, as well as test the transfer rates with another device like an external hard drive for the computer's front and rear USB ports. I would bet on it being a cheap flash drive or possible a poor connection from the front USB port to your motherboard.

You have to be a little bit crazy to keep you from going insane.


Report •

#3
July 5, 2012 at 05:16:53
havoc_14, I think Fingers may have touched on your solution. Seems I recall (gas pain?) that there's a speed difference between front/back ports.
HTH
Ed in Texas

Report •

Related Solutions

#4
July 5, 2012 at 10:09:33
Never heard of a computer that offered both 1.1 and 2.0 ports. Only an add on card would have done that. If the system came new with Windows 7 that would be very unusual to have less than 2.0 usb.

The issue is a calculation but also that has to take into account the load on the system. The system posted ought to move that much maybe in 15 to 25 minutes I'd think. That is no where near 1.1 speeds. It has to be in 2.0. So the issue is what is going on. Is the data compressed, are you doing other hard drive tasks. any processes taking too much time. Use performance monitor to decide.

Hang up and live.


Report •

#5
July 5, 2012 at 10:32:31
jefro, many motherboards of past generations had both USB 1.1 & 2.0 controllers.

Additionally, when a hub is in the circuit the speed will usually drop to USB 1.1.

Card readers may cause the controller they run off of to drop to USB 1.1 speeds. That may be the culprit in this case.


Report •

#6
July 5, 2012 at 14:03:41
That came with windows 7? I'd be more inclined to doubt that . The proof is a usb 1.1 should have been more than 45 minutes. Dunno, maybe it could be a fast 1.1 copy.

Hang up and live.


Report •

#7
July 5, 2012 at 20:41:45
i built the system, its a asus p8p67 deluxe it has usb 3.0 ports in the back and the rest are 2.0, and the model of hte pin drive is a v100w 8 gb, ive tried moving the thumb
drive to the back and even in the 3.0 slots, but i guessing its just the thumb drive itself,
cause the highest speed ive reached is just over 1.3 MB/s with nothing else goin on in backround

Report •

Ask Question