Get wifi to work on used Compaq Presario CQ56 laptop

December 23, 2014 at 18:18:05
Specs: Windows 7, 2.2
I bought a used Compaq Presario CQ56 recently. It works well except that the wifi doesn't work everywhere. It will work on a public wifi, such as AT&T, where you connect to the wifi through the computer, and then agree to the terms on the browser.

It will not work, however, on any other type of wifi, such as a home network, and it will also not work on an ethernet connection. I've checked the password on the network, so I know it's not that.

I think it has something to do with the public network access, but am not sure. What can I do to make it work?

Thanks in advance.


See More: Get wifi to work on used Compaq Presario CQ56 laptop

Report •

#1
December 23, 2014 at 19:49:47
First, there are many standards (a, b, n, ac, etc) of WiFi, some older than others. The public WiFi may be the most tolerant of a laptop that is on an older (or newer) standard but your home WiFi may only support a few of these standards or the legacy standards might be an option that you have to turn on before using it.

Second, are you seeing the WiFi on the laptop, selecting it, and entering the password? Are you not seeing it (the particular WiFI) at all on the laptop? Are you able to access this WiFi from other devices (other computers, tablets, cell phones, etc)?

Third, have you tried reinstalling the latest drivers for the laptop from the mfg's website? Particularly the chipset, LAN, and WiFi drivers would be the ones that would concern you for this but all drivers can be updated and may help an older machine to work better.

You have to be a little bit crazy to keep you from going insane.


Report •

#2
December 24, 2014 at 11:08:45
The home network can be setup to only allow connection for certain items defined by their Mac adresses. This is usually done to disallow random people within the wifi's range to connect.

Nigel

Wind slow


Report •

#3
December 24, 2014 at 12:11:54
It will not work, however, on any other type of wifi, such as a home network, and it will also not work on an ethernet connection.

If it won't work n the cat-5/ethernet connection either then there are a possibly a couple of things to check first... Presumably you are referring to cat-5/ethernet connection with "your" home router?

Look in Device Manager and see if there are any yellow exclamation marks showing in the Network Adapters "branch". If so then start by resolving those...

This link may help re' Device Manager...

http://tinyurl.com/2aotkyj

That you can connect to other wifi (public) networks does suggest that the wifi adapter is OK; though possibly the cat-5/ethernet one isn't. It may be the cat-5/ethernet adapter is simply "switched off" (disabled) on the laptop? Is there an icon in the system tray (bottom right) showing for the cat-5 adapter? There ought to be one for cat-5 and also the wifi adapter. If either is disabled/not working correctly often it will show as such. But again as you appear able to use wifi OK elsewhere, that adapter ought to show as OK in those locations, but not so "at home".

Check Device Manager and see what may or may not be showing there.

Reboot the router and then see if you can connect to it via cat-5. IF not then "reset" the router. This will restore/reset the router setting to the default settings - as delivered.

What make/model router do you have?


Report •

Related Solutions

#4
December 25, 2014 at 20:51:09
The wifi that I use is at my Dad's, it's a Motorola that is used for U-verse and is fairly new. My Dad's laptop is a Vista laptop and can connect, as can my step-brothers computers. The Wireless Network page does show the wifi connection and the network name and password are correct. It says it is connected to the router but not the internet.

I didn't see any problems with the connections. When I tried the cat-5, I took the cat-5 cable that goes to my desktop that does connect to the internet and it didn't work. I will try to reinstall the driver when I can. If you have any more suggestions, I'm all ears.


Report •

#5
December 27, 2014 at 21:57:55
My stepbrother took a look, and found the Wireless Network Connection Properties of the wifi connection and looked at the properties of the Internet Protocol Version 6. It was trying to find an IP address manually instead of connecting to an IP address automatically. He switched to automatically connect and it seems to be working correctly now.

Thanks for the help to those who offered it.


Report •

Ask Question