Explorer.exe doesn't work with all disks

Microsoft Windows 7 professional 64-bit
July 24, 2010 at 03:41:49
Specs: Windows 7 64 bit, i870/4 GB
Problem:

The BlueRay DVD drive of the computer doesn't read all CDROM- or DVD disks (BlueRay disks not tested) while using Microsoft Explorer.exe. The disks are ok because they are easily read in my old computers DVD drive. The disks are also readable by other ways (programs) than explorer.exe.

The seller changed the BD/DVD combo drive to another one and other brand (LG) drive (both BlueRay combo drives with SATA connection). Same result. At last I took my old DVD drive from my old computer and connected it to the new one's IDE connector (with flat cable). Surprisingly now even my old DVD drive didn't read the very same disks it had read in the old computer (using W7 explorer.exe)!

This problem appears after downloading Microsofts system updates through Internet. That's why they didn't notice it in the computer store while assemblig the system up (fresh setup without Internet connection and updates works ok).

I did send the computer back to the seller store and they changed the BD DVD drive and motherboard (to another ones but same type). I tried the BD DVD drive while still in fresh computer store install and it worked ok. Then I connected to Internet and downloaded Microsoft updates. The very same problem appeared again. The DVD drive doesn't read all DVDs or CDROMs that are quite well readable in other computers when I use Windows 7 explorer.exe.

Microsoft has been informed (by the seller) - no response so far. I wonder if it could be something in the motherboard or other equipment (see below). It must be something in the computer system (software or hardware) because good readable disks and all DVD drives behave same way in this computer system.

I used so far in this computer only Microsoft Windows 7's own firewall and Microsoft's virus checking program (free download from Internet).

System:

System case: Nexus Caterpillar Silent + Nexus NX-6000R3 82 plus 630W power
CPU: Intel Core I7-860 2.8 GHz 8MB LBA 1156
Cooler: Nexus XIR-2300
RAM: 2x2GB Kingston KHX1600 C9D3K2 kit
Motherboard: Asus P7P55D-E LX S1156 P55 DDR3 USB3.0 SATA6 ATX
HDD: Seagate barracuda 7200.12 1TB SATA2 32MB (partitioned 150GB + 850GB)
BlueRay DVD writer: Samsung BD Combo 8x Black Ret powered SATA LS
GPU: XFX ATI HD5850 PCI-E 725M 1GB
Keyboard: Logitech Media keyboard 600SX (USB)
Mouse: Microsoft Comfort Optical Mouse 3000 (USB)
System: MS Windows 7 Pro 64-bit (Fin language version)
Display: Asus 26" LCD VW266H HDMI (DVI in use)


See More: Explorer.exe doesnt work with all disks

Report •

#1
July 24, 2010 at 05:30:19
The solution seems evident. Don't install the updates until they are fixed.

Actually, you could isolate which update/s are at fault by using custom install and installing one by one or conversely removing them one by one.

Googling for the update number can usually tell you what the purpose of the update is. That MAY help you figure out which one is responsible.

It could be some sort of a security issue too. Windows 7 may be seeing the files as invasive and blocking them.

If you are correct in your evaluation of why that is happening then MS should eventually patch the problem. Sometimes patches are hardware specific and only occur with certain combinations.

I am curious as to exactly what you mean by Explorer.exe can't read them. Do you mean you can't view the file list or the disk can't be played?


Report •

#2
July 24, 2010 at 10:31:29
The disks are readable, but not with explorer.exe (of W 7). For example there are some program disks from which I can install the programs ok. Also I can read/copy... etc. the folders and files of those disks by some third party explorer like programs like FreeCommander for example. However when I try to access those folders or files with W7 explorer.exe the BD/DVD drive stays reading reading... something for ever and never accomplishes the task.


Report •

#3
July 24, 2010 at 10:43:46
ignore

Report •
Related Solutions


Ask Question