Error message when System DSN is selected

December 7, 2011 at 11:37:15
Specs: Windows 7, 3.00 GHz/8 GB
When I try to configure an ODBC connection I receive the following error message when the System DSN tab is clicked "you are logged on with non-administrative privileges system dsns could not be created". I have full admin rights and I cannot figure out why Windows 7 is telling me this. I have tried numerous things to correct this (disabled the UAC, searched the internet for an answer, etc.). Has anyone ran across this or does anyone have an answer?

Thanks,

bdthomas02


See More: Error message when System DSN is selected

Report •

#1
December 7, 2011 at 12:11:51
I am beginning to thing there is a problem with Windows 7 when it comes to administrative privileges. I am constantly being told I need admin privileges when I attempt to do certain things even though I am logged on with a user that has Admin privileges.

The way I worked round it is to create a user in my own name and give myself complete control of whatever it is I am trying to do. The strange thing is that you need Admin privileges in order to do this so why not what I was trying to do in the first place?

I think it has something to do with the registry. Admin privileges dont always extend to some parts of the registry.

Stuart


Report •
Related Solutions


Ask Question