Solved Error 0x80070091: The directory is not empty

February 2, 2015 at 11:47:13
Specs: Windows 7
Error 0x80070091: The directory is not empty

(Also reports corrupted but invisible files - directory accessible from command prompt)

This is the error message I continually get when trying to delete a directory tree associated with an uninstalled application.

These are the steps I have taken:

1. Run chkdsk /f (and /x). Will not scan even on reboot. Prompts for system restore.

2. Run system restore. Requires chkdsk to be run.

3. Run chkntfs. Negative result.

4. Attempt to take ownership. Allowed.

5. Attempt to change permissions (upgrade). Any and all types of change denied.

6. Run sfc. Negative.

7. Run fsutil with various subcommands. With both this and sfc it was possible to verify both the address and the fact that the subdirectory in question is reported as not empty.

8. Using a disk editor, locate the address (verified also in text mode as being the correct location) and attempt to delete. Access Denied,

9. Run various 3rd party deletion progs (File Assassin, Unlocker etc). Negative.

Next steps were to remove the hard drive, reformat and check. This resulted in a clean drive. A new and identical drive was then fitted in the laptop a disk image of the old drive burnt onto it. It fired up perfectly first time but with EXACTLY the same problem duplicated.

After this the disk image was burnt onto the old drive, which was then checked as an unmounted external drive using all the favourites, again without change.

Disabling TrustedInstaller.exe and replacing attrib.exe with a new copy again yielded no results.

CONCLUSION – it’s not a hardware problem. Am unable to access or delete the directory by any means listed. I’m loath to reinstall everything if there is a solution.

I should add that the drive(s) have been fully checked several times for viral and malware infections, and are verified clean.

Anybody have any ideas how to beat Microshaft on this one?

WINDOWS 7 ULTIMATE - 8GB RAM - ACER 5560 - 500GB FHD

gosssmith

message edited by gosssmith


See More: Error 0x80070091: The directory is not empty

Report •

#1
February 2, 2015 at 12:01:55
✔ Best Answer
I would get ahold of a Unix OS such as Ubuntu or Puppy Linux and
see what that turns up in the problem folder. Either of these can be
run from a CD / DVD or thumb drive, or installed on a secondary
hard drive.

-- Jeff, in Minneapolis


Report •

#2
February 2, 2015 at 14:04:58
Yep, thanks. Am moving towards that.

Thanks again.

message edited by gosssmith


Report •

#3
February 2, 2015 at 14:48:09
It seems Windows can super-hide things. For example on my Win 8.1 with all files set to be visible (including protected ones) there is no $Recycle.bin folder at the root of the C drive. Yet if I do a search it finds it there.

Most likely the S attribute. Did you try the -s attribute from command prompt?

I agree, Linux can plough through anything. Also maybe some Eraser/Move-on-boot program using the context menu in search (if it happens to show there).

Always pop back and let us know the outcome - thanks

message edited by Derek


Report •

Related Solutions

#4
February 2, 2015 at 15:58:14
Yes, thank you. I thought it might be something to do with attributes too but didn't get far with that. Apparently although the directory was empty, the "files" in there were corrupt and unreadable. I say was because I have now solved the issue. Found an old Ubuntu disk, fired it up and deleted the orphan directories in three or four strokes of the del key, gave the three finger salute and hey presto. Ran safe mode, watched the hard drive clatter for ten minutes, rebooted and happy daze!

Thanks to you both for your knowledgeable input!


Report •

#5
February 2, 2015 at 16:10:21
Good news - thanks for popping back with the feedback.

message edited by Derek


Report •

Ask Question