Solved Drive C: HD icon appears as removable device in W7 systray

December 25, 2011 at 06:05:04
Specs: windows 7 ultimate, Intel Dual CPU T3200 / 2gb
Hi guys,

i have a cq40-108tu notebook and i've done a fresh install of windows 7. After the installation all went well. except this weird thing that i've noticed. On the tray icon bar, the drive C: appears to be removable but when i tried to click it, it won't allow to be removed as it says that it is being used.

I'ved checked it under the computer management and it says that the harddrive is ACHI Serial ATA. it just annoys me everytime i'm removing a usb and the drive c: is included in the removable option.

1. what would be the advantage of this if it has?
2. should i leave this thing as is or will it burdens me soon?
3. is there any problem with the drive c: being shown as removable device?

Thanks for your advice guys.


See More: Drive C: HD icon appears as removable device in W7 systray

Report •

#1
December 25, 2011 at 09:23:20
✔ Best Answer
In short because it technically is a removable device.....the sata drive is hot-swappable...meaning you can usually take one out and replace it without shutting down the system...commonly used in larger RAID arrays. So even though you may not have a raid set up, the drive is non the less a removable device. I would probably just leave it. I did find this work around if it is really bothering you, personally, I'd just leave it. This is a solution I posted by anonymous.....I have not personally tried it, but it sounds reasonable if this is bothering you.
After researching this for some time i have finally found a solution in this microsoft-issued document:
http:/ [...] eSATA.docx (link no longer valid)

I'll try to summarize it here, but take a look for yourself if it's not clear enough:
"To work around this problem, you can disable external SATA support on a per-channel basis by setting the value of the TreatAsInternalPort registry key to 1 and then rebooting the system."

What this actually means is that you first need to find out on which channel your drive is connected, and then set a certain registry value accordingly. Do this by going to Device Manager -> Disk Drives; Right click your drive and click Properties. On the General tab look at Location. There are several numbers here, but i think that only "channel" matters to us. My channel was 0.

Now open your registry (with admin privileges) and go to:
HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel0 (change the last digit according to you drive's channel).
If this key doesn't exist you're gonna have to create it (I had to create Controller0\Channel0).
Here create a new DWORD value with the following properties:
Value name: TreatAsInternalPort
Value data: 1
Base: Hexadecimal

You can shorten this process by entering the following in the command line:
reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel0" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001

Now just reboot!



Report •

#2
December 25, 2011 at 09:26:59
Turning off achi in the bios may resolve this as well, I would try that before delving into the registry....if that fails to resolve the issue you can turn it back on and try the above mentioned registry settings.....playing in the registry can have disastrous effects if you make a mistake.

Report •
Related Solutions


Ask Question