Disk boot failure

Asus A8n-sli premium motherboard
March 16, 2011 at 21:23:07
Specs: Windows7 64bit, AMD64 4000 / 4.0 GB
OK, this is an odd one.

On a PC with a recent installation of Win 7 64bit, the system blue screened while installing updates. After restarting the PC I received the error "BOOT DISK FAILURE, INVALID SYSTEM DISK...". Continued to receive the same error after several reboots.

I ran MemTest86 for most of a day (no errors) and also ran several different drive utilities to test the drive for errors (none found). I finally traced the blue screen problem down to an issue with using 4GB of memory on my MoBo. After making the necessary changes to resolve that problem I decided I would need to reinstall Win 7.

Upon first boot I again got the boot disk error as expected, so I popped in the Win 7 install disk, rebooted and walked away for a moment. When I returned a few minutes later to begin the install I was staring at the Win 7 login screen. After logging in and checking that all was fine, I removed the install disk and rebooted. I again got the boot disk error.

So, as long as the install disc is in the DVD drive the system boots fine (into the install on the HD). If not, I receive the boot disk error. I am at a loss as to why this is occuring. Any idea? If I don't get this straitened out my next step will be to run a repair from the install disk. I really don't want to have to install from scratch as the system was already activated.

Michael J


See More: Disk boot failure

Report •

#1
March 16, 2011 at 22:41:02
As it turns out I ended up finding the cause and solution a little while after posting here, A little more searching found this post: http://elitenick.com/2009/10/18/win...

Apparently Win 7 decided to put the MBR on the secondary HD. However, the fix for me was easier than the person in that post stated. All I had to do was disable the secondary HD in the BIOS and boot the system. Oddly, the 2nd HD was still available in Windows (I'm guessing the Plug-n-play feature of the OS overrode the BIOS setting). Anyway, after booting successfully with the 1st HD disavbled in the BIOS, I re-enabled it and it still booted successfully - without the Win 7 disc in the drive.

Michael J


Report •

#2
March 17, 2011 at 20:24:52
Odd that it began happening right after the update. The problem you described would be more typical if you installed Windows or reinstalled with more than one hard drive present at the time, especially if you later tried to remove one drive. It is best to remove or at least unplug all hard drives but the one you are installing it on before you begin. Fixing this usually is simply unplugging the other drives and doing a repair to the installation, then removing any extra boot partitions from the other drives.

You have to be a little bit crazy to keep you from going insane.


Report •
Related Solutions


Ask Question