Disable Autirun.inf on my mobile broadband USB stick

January 28, 2012 at 17:05:12
Specs: Windows 7 Home Premium, Intel Core 2 DuoP8700 2,53GHz/4GB Ram
During the unlocking of my Huawei E5830 MiFi is one simple problem. The unlock software at the end of the unlocking process restarts (what is OK) the device E5830 (I think turn OFF and then ON - the same as yo unplug and plug in) and unlocking process finishes with error code. Why? Because the autorun.inf inside the device starts up installation wizard and blocks the COM port and unlocking software can not recognize device at that port.
I have tried the simplest way - to deactivate autorun in my Windows Home Premium 32bit. But it looks tha it is hardest way. I spent with it all day by browsing the informations how to do it. I have tried many ways how to do it, but all was unsuccessful.

What I have tried:
1. Holding SHIFT key on keyboard does not works for me
2. Adding registry key as :
HKEY_CURRENT_USER_Software_Microsoft_Windows_CurrentVersion_Policies_Explorer
NoDriveAutoRun REG_DWORD 0x000000ff
Does not works too.
3. Even using this reg entry to completely block and disable autorun.inf files on this website:
http://www.sevenforums.com/tutorial...
did not solved my problem.
4. I turned off Autoplay in control panel - no change
5. I did not tried gpedit.msc, because it is not in my version of windows

So I am at end of my ideas. What I can do more? How to stop running autorun .inf

My next idea is to rename Autorun.inf to Autorun.txt and after unlocking rename back to Autorun.inf (or delete it and then copy it back)

But the USB modem behaves as CD. I can not delete or copy anythink on it. Even format it. But I do not want to format it.

My question is:
1. How to turn off autorun on Windows 7 Home Premium 32 bit, or
2. How to rename/delete autorun on my USB device?


My issue is very similar as here:

http://www.computing.net/answers/wi...

but to turn of autorun in my pc is probably impossible. I will shake hands to microsoft guys.

All your advices are welcome and I will be very thankful.


See More: Disable Autirun.inf on my mobile broadband USB stick

Report •

#1
January 29, 2012 at 05:54:04
I suggest you to read this MS KB Article for a probable solution to your issue.

You may have to restart your computer for the changes to take effect.

CoolGuy


Report •

#2
January 29, 2012 at 08:46:29
I did a more examinaion about this issue. Here is good article about Autorun/Autoplay
http://www.online-tech-tips.com/com...

I find out, that if I enable Autoplay in Control panel, autorun works on every device. If I disable Autoplay in Control panel, autorun is disabled for any device (CD, ext. HDD, USB Mass Storage, Phone configured as Mass Storage) except my USB mobile broadband stick.
My USB mobile broadband stick ignore this setting and it runs anyway.
Om "My computer" window it is recognized as "CD Drive (I:) 3 Connect" as CDFS.
1. If on my PC is not installed Conection manager aplication, autorun runs setup wizard for Connection manager aplication. (even autoplay is disabled in control panel)
2. If on my PC is installed Conection manager aplication, autorun runs Connection manager aplication and I am ready connect to internet. (even autoplay is disabled in control panel)

When I connect it to PC, autorun runs connection manager or setup wizard (depend if it is instaled or not) regardless of Autoplay setting. The USB COM port (COM57) is used by connection manager, so I can not establish connection between modem unlocker program and USB modem. When I close connection manager I can establish connection between modem unlocker program and USB modem. Then I run unlock process, but at the end of the unlocking process it requires modem reset (turn OFF and ON). At the end of the unlocking process, when the modem is turned ON, windows detects the modem device (as it would be pluged in) and autorun runs again connection manager (or setup wizard), what blocks COM57 port for modem unlocker program, unlocker program can not reestablish connection and unlocking process finishes with error. This happened to me with two different unlocker program. Both ofthem need modem reset. And that makes me trouble.

I wilcome any advices, how to solve it issue. Thanks in afvance.


Report •

#3
January 29, 2012 at 20:26:50
I use a USB protector by Panda anti virus and it prevents files for changing autorun.inf

Fixing computers we had issues with viruses copying to usb sticks so I use Panda USB Vacine. google it. It disables autorun


Report •

Related Solutions

#4
January 30, 2012 at 00:47:20
Please visit Uwe Sieber's site and download Autorun Settings v1.3 that may help resolve the issue, hopefully.

CoolGuy


Report •

#5
February 3, 2012 at 10:25:24
Uff, problem finaly solved (after 5 days). I have had installed O2 broadband (Ireland) connection wizard. I did not uninstall it, because I stil used it (threre were saved more profiles as O2, Meteor and 3Ireland) and I want to use it in case I will unnlock E5830.
I find out that the setup wizard placed Autorun folder in to C:\Program Files\O2\O2 Broadband USB Modem\O2 Broadband\AutoRun and there were two files:
- AutoRunSetup.exe
- AutoRunUninstall.exe

I ran AutoRunUninstall.exe . File AutoRunSetup.exe has dissappeared and there appeared two more files DeleteFile.exe a DelFile.bat. After few second all these 3 files (AutoRunUninstall.exe, DeleteFile.exe, DelFile.bat) has dissappeared. The folder Autorun remained empty. o restart was necessary. After this, my problem has been solved, and when I attached my UBS modem, no connection magager was opened. Now finaly autorun was disabled.

:-D


Report •

#6
November 24, 2012 at 08:53:31
^^ Thanks. I was looking for a solution in google for the exact same problem and I was lucky I found this thread. The file AutoRunUninstall.exe, I've seen it while I was tweaking the software, but never thought of uninstalling it. Thanks a lot. This worked like a charm!!!

Report •

Ask Question