Device mngr empty-can't upgrade-can't restore

April 10, 2011 at 21:06:09
Specs: Windows 7, i7-2600@3.2GHz 12 gb ram
Last week I tried booting up my 3-month old Dell xps 8300 and I got a blank screen. I pulled the plug rebooted and Win 7 64-bit home edition started with this error message: “No ATI graphics driver is installed, or the ATI driver is not functioning properly.”

Went to device manager and It was empty. I opened it several different ways but there was never anything in it. Plug and Play is listed as “started.” I ran a full scan with Microsoft Security Essentials and Malwarebytes. No malware found. Win 7 troubleshooting found nothing. I upgraded the bios and chipset. Ran system maintenance. Ran disk cleanup. Nothing changed.

I tried to do a system restore but it would not restore. I got: "System Restore did not complete successfully. Your computer’s system files and settings were not changed. Details: The creation of a shadow copy has timed out. Try this operation again. (0x81000101)" When I tried again I got this message: System Restore There was an unexpected error: catastrophic failure (0x8000FFFF) Please close system restore and try again.”

I installed a new video driver from Dell and that got rid of the ATI message but I still had nothing in device manager. There were also some possibly related side problems. Media player freezing a couple times. DVD files that wouldn’t open, then would later. And there’s nothing in my Dell Document Viewer when I try to “List Topics” or when I try to “search.” I am also unable to update to the Win 7 Service pack. I ran the installer troubleshooter twice. It reported both times it had fixed something but not well enough for the download to work. The installation fails in the reboot. I got a “Code BC9“ error. The last error message was: E_FAIL(0x80004005).

Dell tech support couldn’t get device manager to display either. She ran sfc/scannow (no integrity violations), the Dell diagnostic test (f12 at the Dell screen, no problems found), and downloaded a different video driver. That didn’t help. She tried changing the enum parameters but couldn’t save the changes - because of that she decided it was a registry problem. I went into Advanced Security settings for Enum later but got stopped at "Replace owner on subcontainers and objects" with the message: "Registry Editor could not set owner on the key currently selected, or some of its subkeys."

Still nothing in device manager. That is not a huge problem yet but, with the other problems, I’m guessing things will get worse. A clean boot (http://support.microsoft.com/kb/929135) has been suggested but that seems a little tricky and this week I can’t afford this computer to be down. I will try that next week. Any other suggestions?


See More: Device mngr empty-cant upgrade-cant restore

Report •

#1
April 10, 2011 at 23:18:52
1. Error Checking- CD not needed
Start - my computer - right click local disk (C) - properties - Tools Tab -
Error checking section - Check now - check mark both boxes - Start -
This requires a restart to begin.

Save your documents to a DVD

Have you made your System Recovery Disks ? Your allowed to make
one copy.
If you have Broadbad (high speed Internet) with the Recovery Disk it
wouldn't take long to reinstall Windows 7
To stop future problems try an Exterior Hard Drive and a backup system
like Acronis. Takes about 25 minutes to run a backup and completely
restore a computer.
This can be done also in a different manner, like using the Recovery Disk
and than running the Acronis backup.


Report •

#2
April 11, 2011 at 09:41:10
Create a system repair disk. Then boot to this disk, this will allow you to run your System restore from the files on the disk and has worked for me repairing a system that could not run system restore from within the OS. This saved a lot of time reinstalling windows, programs and back ups and was running properly withing minutes. The problem I needed solving involved the print spooler that was not working and could not be activated in services and through other online instructions I found and since I had already tried system restore and failed, this was the last tool I had (or needed) before reinstalling. It still uses your system restore points which are not damaged, but bypasses the damaged system files that are not letting you restore. This disk was made months prior, but it still may be able to make a good repair disk you can use.

You have to be a little bit crazy to keep you from going insane.


Report •

#3
April 22, 2011 at 09:42:38
Things went to hell in a hand basket shortly after this. Icons took a long time to appear and then took an hour before they would connect. Programs froze. Dell replaced the hard drive and that fixed the problem.

Report •
Related Solutions


Ask Question