Cut and paste in a DOS command prompt pastes it twice

April 11, 2017 at 08:46:09
Specs: Windows 7 pro, 16GB
I notice lately that on W7 in a DOS command prompt, when I highlight a filename and press enter to put in the clipboard, when I right click to paste it at the command prompt it appears twice - back to back. This happens often and is annoying. Has anyone seen this or know what is happening. I have been doing this for many years and this is a relatively recent occurrence.

See More: Cut and paste in a DOS command prompt pastes it twice

Report •

#1
April 11, 2017 at 08:49:43
Does the double text happen if you paste to, say, Notepad? If not, try a different mouse. It sounds like your right mouse button might be on the way out.

How To Ask Questions The Smart Way


Report •

#2
April 11, 2017 at 09:18:02
I don't use notepad too often. For an editor I use KEDIT (I'm an old mainframe guy) and never noticed it happening in that program. However, you might be right. this mouse is old - maybe 10+ years. I'm not sure if it happens in my W10 system which shares the mouse via a KVM switch. I probably have other mice and will switch the mouse and see what happens. Thanks.

Report •

#3
April 12, 2017 at 07:12:03
Just for giggles remove the mouse from th KVM and plug it directly into the computer, you might have something strange going on with a channel on your KVM.

Report •

Related Solutions

#4
April 13, 2017 at 05:25:58
What happens If you select the Edit/Paste option from the File menu in the Command window? Does it still paste twice?

Report •

#5
April 13, 2017 at 05:38:34
It only happens at a command prompt ('>') in a DOS command box (window). I'm an old timer and have used DOS literally for decades. There's many things I can do faster that way and have written many tools that get executed from the command prompt. Cutting and pasting in that environment is something I do very, very often.

Report •

#6
April 18, 2017 at 05:56:59
So if you select Edit, Paste, it doesn't paste twice? Or it does?

Report •

#7
April 26, 2017 at 11:44:04
changing the mouse seems to have solved the problem. I haven't seen it since.

Report •

Ask Question