Connection blocked for browsers?

March 12, 2011 at 01:35:02
Specs: Windows 7, 2 GB
earlier i I have installed norton inetrnet security 2010 on my windows 7, now when i try to open it ,there is no response. even uninstalling is not working. on clicking uninstall nothing happens.
even internet is not working in browser, it appers connection is blocked by remote server. but it's working in internet explorer. plz help me out from this problem...

See More: Connection blocked for browsers?

Report •

#1
March 12, 2011 at 02:31:26
System restore back to before you installed Norton, and do not install that crap software again. Microsoft Security eEssentials is better and FREE !

Report •

#2
March 12, 2011 at 04:11:04
no system restore point before nis installation. is there any other solution?

Report •

#3
March 12, 2011 at 19:10:57
Unless you have system restore turned off, system restore automatically creates a restore point every time a program is installed. Try clicking 'show more restore points' when you open system restore. That should help.

Get the uninstaller from Norton's (Symantic) site and use it to get rid of that nonsense from your computer. Stay away from that overpriced bloatware, you are paying for all of the advertising and promotion they do to keep people believing they are good. If they put half that money and effort into making it a truly good lean effective program, they would not need that much advertising. (McAfee is just about the same, so don't bother with that either) Use MS Security Essentials (free), Avast (free version, just register it), or Webroot (my preference, but not free)

You have to be a little bit crazy to keep you from going insane.


Report •
Related Solutions


Ask Question