Chrome Does Not Load Anything

March 23, 2013 at 01:48:18
Specs: Windows 7
When I open Chrome, nothing happens, the loading symbol is at the top left of the page, however it just stay a white screen with the toobar. I tried to open new tabs however the same problem occrus.
I know it isn't my internet because Internet Explorer is still working, however this isnt suffice as it is too slow.

See More: Chrome Does Not Load Anything

Report •

#1
March 23, 2013 at 04:56:55
Uninstall Chrome, then re-install it: https://www.google.com/intl/en_uk/c...

Report •

#2
March 23, 2013 at 09:58:26
I would do a quick scan with Malwarebytes
http://www.filehippo.com/download_m...
and fix all it finds...you may be infected, so better to be safe than sorry.

Some HELP in posting on Computing.net plus free progs and instructions 7 Golds


Report •

#3
May 2, 2013 at 14:55:55
I too had similar issue with Google chrome NOT opening the typed in address on the tabs. My computer is Windows 8, however I work off of desktop in a windows 7 type of program. The other day I cleaned up, deleted many cookies, browsing history and when I refreshed, many apps had been removed. No worries. An icon appeared on desktop listing 'removed apps', easily enabling me to reinstall the ones I wanted with no difficulties. Google chrome ALSO reinstalled and now works beautifully. Did NOT lose downloaded files likes pictures nor bookmarks when I refreshed. When I reinstalled iTunes, all my music was there

Report •
Related Solutions


Ask Question