changing w7/64 partition's position on drive?

Microsoft Windows vista home premium (oe...
March 28, 2016 at 09:52:52
Specs: windows 7 pro 64, 32gb
i have a dual-boot 250gb ssd system drive and have been trying, unsuccessfully, to move it to a 500gb ssd. my hope is to add space to both os partitions. the first is non-windows, the second is w7/64 pro. drive is gpt with efi partition.

i've successfully cloned the drive with it's partitions copying to the new drive in the exact geometry as the original and leaving lots of space following. the failure occurs when i try to move and resize the partitions. obviously, to make room for more space on the first, non-windows, partition i have to move the windows partition farther down the drive to open space before it. as soon as i do this, windows becomes unbootable and i haven't found a clear solution to overcome it. it appears that changing the start location of the partition is what is causing the issue but i haven't been able to figure out what to edit or how in order to fix it. is this even possible now?

any info, guides, etc are much appreciated. i've used linux-based tools so far and, for the cloning, they worked fine (clonezilla, systemrescuecd, ntfsclone, dd, gparted, fdisk, etc). it breaks down in getting things set up the way i want to take advantage of the new space (moving the windows partition).

i should add that i have tried running repair from the original installation dvd and that hasn't helped. it couldn't even find the os. tried bootrec in various ways too. no luck. there must be something that can be edited to make this work - right?

thanks,
BabaG


See More: changing w7/64 partitions position on drive?

Report •

#1
March 28, 2016 at 10:58:46
Right, there might be.
Ok you mentioned GParted, I was about to mention that just after seeing the heading of your question.
Well, how did you try to copy the drive from the 250GB one to the 500GB one? Through windows?? And, are both the drives connected to your PC at startup? Yes, NTFS should be prefered above any other formats.
Well, first thing's first, answer me with the queries I asked for.

Report •

#2
March 28, 2016 at 11:38:58
thanks, jaysarma.

i've cloned the drive using clonezilla. that worked but i couldn't later resize while retaining bootability. i do not have both drives plugged in when trying to restart. i've always done the cloning, then unplugged the source drive.

i've also used a lot of command line utilities from systemrescuecd as detailed here:

https://www.system-rescue-cd.org/fo...

again, this cloning worked but i could not figure out how to later move the windows partition while retaining bootability. whenever i've tried to move the windows partition to a later part of the drive (to free space to enlarge the first partition) windows becomes unbootable. i've generally done this by first cloning, then trying to move the partition.

i have tried pre-partitioning the drive and restoring an image to the pre-partitioned location, which is later in the drive. copying the gpt and efi partition seems to carry info, though, that caused that partitioning scheme to remake itself to conform to the original drive's layout.

i'm guessing that the issue is in the efi and gpt data but have no idea how to conform that to the layout i want. no experience there.

thanks again,
BabaG

message edited by BabaG


Report •

#3
March 28, 2016 at 19:52:04
Most SSD drive mfg's offer their own software to clone your original drive over to the new drive, usually as a download. This option should have more flexibility on the cloning and better instructions as well.
Please note that you can also leave the primary Windows partition size alone and add a new partition specifically for storage which will free up space on your C drive for your OS and programs.

You have to be a little bit crazy to keep you from going insane.


Report •

Related Solutions

#4
March 28, 2016 at 20:18:01
Yes, and additionally, moving the windows partition to any other place of the drive makes it unbootable. The place where boot sector is written needs to access data of windows from a specified location only, altering it would not work.
You said one of your OSes is not windows, you're using linux too? What's your bootloader, Grub or Lilo?

Report •

#5
March 30, 2016 at 01:23:35
BabaG:

I faced the same situation, and had tried many of the same 'tools': e.g. PartEd Magic, GParted, Windows system image/restore and shrink/expand... with the same result: failure to load the system. With hard disks, this had never been much of an issue using the various utilities mentioned above (along with EasyBCD, MBR repair, etc).

THEN, somewhere in my online quest for a solution, someone (Intel's SSD support forum?) mentioned success with EaseUS Partition Master Free.

Being at my wits end, I tried EaseUS... and it worked.

message edited by TheChairman


Report •

#6
March 30, 2016 at 10:27:22
thanks everybody. i finally got the system running. it's not an ideal solution but, for now, it's working. will watch it for a while before i call it finished, though.

i also tried easeus but, for me, it didn't work.

someone on another board suggested using imaging rather than cloning, something i was gradually coming 'round to myself, and that's what worked, though, it's been a pretty rocky road. here's how the process went:

i started with trying to pre-partition the drive to the sizes i wanted. for that i used gparted. then i restored an image of the windows partition to partition 3. it had been on partition 3 on the original drive but at roughly 120gb into the drive. the new partition has it at about 200gb in.

i could never get that installation working so i went back to the w7 install disk to try repairs. none worked. then i tried a fresh install, thinking i would let windows take over. i started the install but cancelled after the formatting. that may have been what worked. it seems to have used my partitions but applied some of its own secret sauce somewhere.

i reinstalled the image, just as i had before, and went back to the w7 install disk to try to repair the installation, assuming the boot partition and folders would need work. that took many rounds of, sometimes contradictory, info and repair. sometimes the repair would find the installation and report it as 120gb (the original partition size) and sometimes as 300gb (the new size). i ran bootrec commands as well.

eventually, windows did repair itself and was able to boot. then i installed the hfs+ partition from its image and was able to use tools associated with that system to get it running as well. both systems are now booting, apparently properly, and seem to run well. the only thing that now has me scratching my head and a little dubious is that the disk reports as an mbr disk where the original was gpt. gpt is what i'd been trying to set up on the new one but, i assume, the windows installation disk had other ideas and that's where the change happened. it does seem to be working, though.

thanks and hope this is helpful to someone.
BabaG

message edited by BabaG


Report •

#7
March 30, 2016 at 17:22:01
Imaging! Yes, didn't thought that would work.

message edited by jaysarma987


Report •

Ask Question