Solved Can't move or delete files for no reason

Microsoft Windows 7 ultimate 32-bit
July 25, 2010 at 15:53:49
Specs: Windows 7, AMD Phenom II X3, 2GB RAM
I recently installed a fresh copy of Win7 but now I can't move or delete SOME files for no obvious reason.. Windows tells that I need permission.

Here are my observations:
This happens randomly for any files and folders.
I'm quite sure no programs are using the items.
I'm sure I have no viruses.
I'm administrator.
Indexing service is off.
This happened only on Win7. Even when I reinstall windows, it comes back after some days.
When I restart explorer.exe It's solved TEMPORARILY.
I haven't messed with security settings.
UAC is disabled.
I restart PC but still files are locked.
I used a software called unlocker to force deletion or move but no good
It's very annoying.
Am I doing something wrong?

I'd appreciate any help, please...
I don't want to restart explorer.exe every time I want to change something.


See More: Cant move or delete files for no reason

Report •

#1
July 25, 2010 at 21:22:13
✔ Best Answer
You may need to take ownership of the files/ folders. Google for that phrase to see lots of threads on the topic. Or follow the link below.

http://www.google.com/search?q=how+...


Report •

#2
July 26, 2010 at 01:09:25
I already tried that
I forgot to mention that the message doesn't only show that I need permission but also sometimes it's file/folder in use.
I searched for this issue and found other users having the same issue but only for items on the desktop and the solution is...
guess what.. restart explorer.exe
I'm desperate, I think I'm going back to Vista
But thanks any way.

Report •
Related Solutions


Ask Question