cannot see USB hard drive

November 13, 2012 at 04:43:10
Specs: Windows 7, AMD Turion 2.4GHz/4GB RAM
My regualr laptop's motherboard has fried, so I broke out an old laptop, reformatted the HD and fresh installed windows 7 temporally until I get my regular one fixed. My old laptop is an older model but top of the line for its day. I also have an external USB hard drive which i "planned" putting my HD from my new laptop into to access some much needed files. My problem is when I plug this USB HD into my old laptop, windows detects the HD in the disk manager window, but nothing displays in the computer window. I also noticed that in the disk managment window the USB HD from my new laptop is listed as not having a file system, as opposed to the NTFS that it should be. I right click on the drive/partition and all of the options in the menu are grayed out except properties.

Now I dont know if this has anything to do with it, but like i said, my old laptop (the one im on now) is quite old and the HD connection (internal HD) is IDE where my new laptop and external USB case is a Sata drive connection. I only suggest this as being the problem because also the Sata HD that came with the USB case is having the same problem... Detected by computer management, but not able to view it in my computer. I do have a second External HD that is an IDE connection and when plugged it, this one works just fine.

How can I access the files on my new laptops HD from my old laptop while having this problem and keeping the file system and partitions in tact so when I repair my new laptop I can put the HD back in and not have to worry about re-installing the OS and software. Also, on a different forum asking the same question, someone suggested booting from a USB drive/stick to some sort of file recovery system. Where this would be a temp solution, my laptop does not support booting from USB, so that would not work.

See More: cannot see USB hard drive

Report •

November 13, 2012 at 05:08:53
First of all, how do you know the motherboard in the old laptop is fried? If you are correct then the file system on the hard drive may be damaged. You can try to repair the file system by using Easeus partition manager. See the link below.

Post all information you do see in Windows Disk Management for the drive in question, including properties. Did you jumper the drive as required by the USB enclosure in question?

Windows 7 security measures may not allow you to see files on the old drive due to access restrictions. If that is the case we can deal with that after determining the actual problem.

The SATA USB drive may need to be partitioned and formatted before it will show in Computer.

Report •

November 13, 2012 at 05:12:43
You could try booting to a CD with Puppy Linux on it (not install) and see if it has access to the drive. If it does, just copy over what you need to the laptop and switch back to Windows (do not forget to 'unmount the drive' in Linux before restarting).

This maybe a case that the external case is not very compatible with the older hardware. You can also try a different brand external SATA/USB case since they are not very expensive.

You have to be a little bit crazy to keep you from going insane.

Report •

November 13, 2012 at 10:30:25
You typed a lot but not a single shred of info about your laptops or drives. But if your "quite old" laptop is running Win9x/ME, it won't recognize an NFTS partition.

Report •

Related Solutions

November 13, 2012 at 16:43:27
As for the problem with my newer laptop: I am about 99.5% sure its the motherboard or at least the graphics adapter, which would mean i would need a new motherboard anyway. Its a long story about the whole problem, but the end result now is that when I power it on, I get the HP logo for about 1 second (before the bios and boot options even are displayed) then the screen goes blank. I can see a motherboard fried possibly causing a problem in the file system of the HD, but since I am having the same problem with a different Sata HD that was never connected recently to my new one during my issues with it, I cant see that being too much of a possibility. Disk management information is as follows:

Disk 1;Basic;111.GB;Online
Partition1: volume: displays nothing, Layout:Simple, Type:Basic, File System: displays nothing, Status: Healthy (EFI SystemPartition).
Partition 2: same as partition 1 except Status: Healthy (Primary Partition)

Forgive me, i was worng before when I said I can access the properties. I cannot, it is greyed out like the rest of the menus/options.
I never jumpered the drive nor do I recall any documentation from the enclosure telling me to do so.


My "old" laptop is a compaq presario R3000. Native to XP, but now has 7 Home installed. It has knows compatability issues with 7, but mostly graphics card issues, which led me to buy my "new" laptop and give up on the upgrade. My "new" laptop (the one with the motherboard issue) is a HP DV7 series. Windows 7 home.

Report •

November 13, 2012 at 17:21:20
Is a drive letter being assigned? If not, try assigning a drive letter to Partitiion 2. The partition may not be marked as active either.

I thought you said the old hard drive was an IDE model. IDE drives have Master/slave/cable select jumper settings. Enclosures require the jumpers to be set a certain way. It depends on the enclosure.

Report •

November 13, 2012 at 20:32:08
There is no option to assign or change a drive letter to the drive. Well there is, but that option is greyed out in the disk management window. Is there another way?

I think we may be getting confused with this "old" and "new" hard drive talk. my "old" HD that I am saying is IDE is the original HD that came with my old laptop and is still inside it. I have never taken that out nor needed to mess with any jumpers on it. My "new" HD is from my new laptop (the one who's motherboard is bad) and this one is a Sata drive. I took it out of my new/broken laptop and placed it into an external USB HD Sata case to try to get some files off of it. This HD does not even have any jumpers to be set (not that they dont need to be set, but it actually doesn't have any jumpers)

I tried Fingers suggestion and booted into Puppy Linux. I was able to transfer the needed files to my old laptops HD, so the problem is somewhat solved, however I'm the type of person that needs to know WHY it isn't working the right way and will not be able to rest until I find a solution. I would still like assistance if you have any other suggestions.


Report •

November 14, 2012 at 05:08:57
Can you post a link to your USB-SATA enclosure ? Does your enclosure have lights on it indicating that it is receiving power and HDD inside is spinning ? Is it USB BUS-powered or does it have external power adapter ?


Report •

November 14, 2012 at 10:28:01
When viewing the USB drive in Linux, is the drive assigned drive letter/s?

Report •

November 15, 2012 at 13:27:19
Im not sure the who makes it and dont have the documentation for it anymore, but here is a link to the site I bought it from (I think they make it themselves).

Yes the lights do come on and I can hear it spinning. It is also USB powered, No external power adapter.

To be completely honest, I have never used Linux before. I had to mount each partition separately and I dont remember it having a drive letter, but something more like a path of (I cant remember exactly) /mount/USB1/users...

Report •

November 15, 2012 at 13:55:13
Yea, USB drives may be labeled like that in Linux. I don't have much time with it either.

Report •

Ask Question