cannot connect to the internet through zte three dongle

January 14, 2012 at 09:49:31
Specs: Windows 64
Hi, I am helping a friend with his laptop. It is a Packard Bell Easy note TJ67 laptop on windows 7. He had a virus so I used system restore to roll it back a month and then installed AVG, Superantispyware and adaware to clean up the laptop, which seemed to work fine. The laptop works fine now except for the 3 dongle which I cant get to connect to the internet. I have used the 3 dongle on my other laptop, and the dongle works fine. It installs its own software and drivers and then connects to the internet. I have run a virus scan on the dongle and it is clear. I install the dongle on the packard bell laptop, the drivers all install correctly and the software loads up fine. It even has signal and then when I click the connect button (using the three software) i get the message "The connection attempt failed, Make sure your device is connected to your computer and that your settings are correct Would you like to connect again?" I try to connect via dial up on internet explorer and i get the message "Error 633 the device is already in use or is not configured properly"

I can connect to the internet fine through my home wireless system (which is no good to my friend who wants to connect via the dongle at home.

So in short
1) Laptop is fine and have scanned thouroughly for virus and cleaned up
2) Laptop connects to internet through my BT wireless
3) Dongle works on 2 other computers fine
4) Dongle will not connect to internet through packard bell laptop but it worked fine before the virus infection.

Any idea would be gratefully appreciated.

See More: cannot connect to the internet through zte three dongle

Report •

January 14, 2012 at 09:54:32
Just to add ,

When I am in in device manager, all is fine, I tried to query the modem and I got
"The port that the modem is attached to could not be opened. This may be the result of a hardware conflict" There are no warning signs in device manager. Thanks

Report •

January 14, 2012 at 10:10:47
sorry not to put all in one post.

have put results of ipconfig on

after seeing this request on similar posts

Report •

January 14, 2012 at 14:54:06
I have the same dongle and there is a driver available for Windows 7. I got the driver here:

Report •

Related Solutions

January 14, 2012 at 16:06:09
thanks, but I cant access the website, it is for New Zealand and Australia residents only and i am in the uk

Report •

January 14, 2012 at 20:17:31
There must be a ZTE distributor in the UK, you may get more information here:

Found this as well:

Report •

January 16, 2012 at 12:54:31
i cant find any updated drivers. But I am farely sure it is not a driver problem. I have installed and uninstalled the dongle several times. The dongle has worked on this laptop before it got infected. When i try to update the driver, windows says it already has the most up to date driver.

This laptop did have other makes of dongle on it before (vodafone) . I wonder if it is in conflict, as I did a system restore, and i wonder if somehow the laptop is wanting or conflicting with that?

I am still confused.

Report •

January 16, 2012 at 14:38:23
Revo Uninstaller has a free edition and it is an absolute whizz at finding leftover stuff from a previous installation (if in fact Vodaphone was uninstalled at all) and it may help you to clear the old utility from your system. Other than that I can't offer any further advice. Th link I gave for the Australian ZTE have a support page and they may just be able to offer some advice. Then there is also ZTE themselves here: they may be able to offer more advice.


Report •

January 21, 2012 at 05:03:05
thanks for your time

Report •

Ask Question