Solved Broadcom no bootable device, entering grub rescue - help?

June 8, 2017 at 21:26:20
Specs: Win 7 Ubuntu dual boot
My Acer AO75 notebook isn't booting. Has dual boot Win 7 and Ubuntu. It's been great for four years.

Noticed that it was going to automatically reboot in 10 minutes to upgrade (usual windows update notification in the lower right had corner). Decided to try and finish in 10 min. Was using PowerPoint, nothing special.

Then blue screen. Reset. Got to the typical ACER opening screen, then "Read error." Then nothing.

Tried F2 at next boot. Seems like it still recognizes my hard drive. Chose exit without saving.

Then...
Broadcom UNDI PXE-2.1 v.15.0.11
Copyright info...
PXE-E61: media test failure, check cable
PXE-MOF: Exiting Broadcom PXE ROM.
No bootable device -- insert boot disk and press any key

Couldn't find my Ubuntu live flash. Just hit a key to see what'd happen. Repeated this all. Tried again.

Then!
Entering rescue mode...
Grub rescue>

So I've had Ubuntu but never did much technical with it these years. I don't know what I can do here.

Tried this after a Google search (link below):
grub rescue> set pager=1
grub rescue > ls

Which returned:
(hd0) (hd 0,msdos3) (hd0, msdos2) (hd0, msdos1)

But I couldn't figure out whether the next commands on that page were going to help or not, so I chickened out.

That page is here:
https://www.linux.com/learn/how-res...

I also tried:
grub rescue> set

Which returned:
cmdpath=(hd0)
pager=1
prefix=(hd0, msdos6)/boot/grub
root=hd0,msdos6

Found this page. Help? :)

message edited by edislost


See More: Broadcom no bootable device, entering grub rescue - help?

Report •

#1
June 8, 2017 at 23:02:53
Sounds like your hard disk is corrupted or damaged. I think you need to reinstall Windows (and possibly Ubuntu too).

Report •

#2
June 9, 2017 at 02:37:09
✔ Best Answer
4 Years with the same HDD?
Now is the time to get anything valuable off the HDD if not backed up.
Use the Live Linux CD or If you have a USB SATA enclosure/cable, copy your important data to another device.

Suggest to get a new HDD (or SSD) and reinstall Windows.

If you need LINUX for educational/tryout purposes, I suggest to install a Virtual Machine like Oracle VM or VMware player, both free for non commercial use.


Report •

#3
June 15, 2017 at 22:28:25
In the end, I figured out my BIOS still works AND my hard drive still works. So I opened the laptop up, pulled out my hard drive, put it in an external SATA case and backed it up.

Not sure if it's worth it to take it to the shop to see if we can fix whatever's messed up the connection between hard drive and the system, but for now, I'm running the PC off Ubuntu on a stick. (F12 at start up, boot from USB, skipped network boot)

Lol. Also backed up that notebook's hard drive from that same notebook... running its own hard drive as an external drive. Incidentally, I can plug that external drive in and boot Ubuntu that way too still, but Win 7 will not start at all, not even safe mode or ACER recovery.

Another lesson: regular backups. Thankfully I still have my hard drive, but it was some work.

message edited by edislost


Report •

Related Solutions

#4
June 16, 2017 at 11:56:03
Create a bootable cd

http://www.supergrubdisk.org/

larry


Report •

Ask Question