Boot error with BCD file

November 20, 2011 at 15:47:49
Specs: Windows 7, 2.6Ghz/6G
I've posted this around a few times, so I hope you guys don't mind me just pasting it in!

I'm trying to fix a mate's PC, but I've run out of ideas. Upon boot, it goes all the way through to the "starting windows" screen, but after that the computer restarts.

From what he's said, he installed some windows updates and it forced the restart. Looks like these were installed on 31/10/11, because there is a system restore point from that date, saying "critical update".

I have a PuppyLinux live USB that I have tried to boot from, but whenever I choose it at the boot menu, I get an error "Remove disks or other media. Press any key to restart" which won't go away until I take out the live USB.

If I force it into system recovery, it finds no errors anywhere; my mate has never created a system image, so I can't restore to that, and system restore always gives me the error "System restore did not complete successfully. Your computer's system files and settings were not changed. Details: An unspecified error occured during system restore (0x800700b7)." I've tried this with all available restore points, and it's always the same.

I have only once been able to get anything more to happen - I have gotten into Safe Mode (once), restored, and it said that restore was successful and the computer needed to restart. I figured the only way to find out if it had worked was to restart it... and now I'm stuck again. The problem here is that I did it by pressing f8 at a certain point during the boot process; usually, f8 loads the boot device options, and has only this one time loaded the option for safe mode. I have tried a lot of times, but I can't get safe mode back to try to edit registry keys or anything (as per some of the solutions google offers).
Anyone have any clue as to how to rectify this? I can't think of any other ways to fix it short of a complete reinstall of windows... and the owner of the PC REALLY doesn't wan't to go that way.


UPDATE: Okay. I've gotten a liveUSB working, and we've also found a W7 boot disk, through which I've tried repairing stuff... I've fiddled a lot, so I can't remember my exact process, but now, if I have automatic restart on system failure disabled, I get an error 0xc000000f. Apparently my BCD file is corrupted. I've attempted to repair this using bcdedit (basically tried all the stuff in http://answers.microsoft.com/en-us/... ) but to no avail.

So much as I can remember, I tried the suggestion of preventing the reboot upon fail, and got an error code (can't remember what it was now). I got the W7 disk to work and went through the solutions for it, and one was to do the startup repair thing, then open the command prompt and run startup repair. This (for the first time) said it was successful, I restarted and now I have the 0xc0 error.

The startup repair now finds errors as it checks, and sometimes says it has resolved them, but when I restart, it hasn't. I can also now get into safe mode.


See More: Boot error with BCD file

Report •

#1
November 21, 2011 at 00:55:08
How about trying EasyBCD (Google for it) to see if that can sort out your problem.

Report •

#2
November 25, 2011 at 16:35:28
Those startup repairs sometimes have to be done several times (3 is generally adequate ) in order to correct the entire boot sequence. Also, now that you're in Safe Mode (which tells me your BCD repair is working as far as it has gone), you could try the system restore again, but doing so would undo the work you've done. I would run through the startup repairs a bit more before resorting to restore.

Report •
Related Solutions


Ask Question